Toolbar button border stays when modal dialog is displayed from a toolbar button

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: mkaply, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Bug 616156 fixed a bug where borders were displayed on any toolbar button, including addon toolbars.

In looking at this fix, I found a new problem.

If a toolbar button displays a modal dialog, when that button is clicked, the border appears and when the mouse is moved away, it stays there.

If you click cancel on the dialog, the border still stays there. 

It doesn't disappear until you move the mouse after cancelling the dialog.

On FF 3.6, it disappears immediately.
(Reporter)

Updated

8 years ago
Blocks: 616156
Keywords: regression
Bug 616156 certainly didn't regress this, and it's not a theme bug.
No longer blocks: 616156
Component: Theme → General
Product: Firefox → Core
QA Contact: theme → general
20160502172042 Mozilla/5.0 (Windows NT 6.1; rv:46.0) Gecko/20100101 Firefox/46.0
20160605030215 Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

I have tested your issue on latest FF release 46.0.1 and latest Nightly build and could not reproduce it.
Is this still reproducible on your end ? If yes, can you please retest this using latest FF release and latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).
(Reporter)

Comment 3

2 years ago
5 years old. Marking WFM based on the test comment.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.