Last Comment Bug 630253 - SeaMonkey Menu gone after updating from non-omni.jar build to a omni.jar build
: SeaMonkey Menu gone after updating from non-omni.jar build to a omni.jar build
Status: VERIFIED FIXED
: regression
Product: SeaMonkey
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: x86 Mac OS X
: -- major (vote)
: seamonkey2.1b2
Assigned To: Robert Kaiser
:
:
Mentors:
Depends on:
Blocks: 588067
  Show dependency treegraph
 
Reported: 2011-01-31 10:32 PST by Adrian Kalla [:adriank]
Modified: 2011-02-02 09:17 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
b2+


Attachments
updater log (119.62 KB, text/plain)
2011-01-31 10:32 PST, Adrian Kalla [:adriank]
no flags Details
file list from an updated build (19.52 KB, text/plain)
2011-02-01 02:26 PST, Adrian Kalla [:adriank]
no flags Details
file list from a clean install (6.75 KB, text/plain)
2011-02-01 02:28 PST, Adrian Kalla [:adriank]
no flags Details
don't remove res/ (648 bytes, patch)
2011-02-01 09:19 PST, Robert Kaiser
bugspam.Callek: review+
Details | Diff | Splinter Review

Description Adrian Kalla [:adriank] 2011-01-31 10:32:58 PST
Created attachment 508453 [details]
updater log

Since the omni.jar landing, when updating from a non-omni.jar build to a omni.jar build on OSX, the menu ("Mac-menu") is gone from all SeaMonkey windows.

The problem results from the entire "Contents/MacOS/res/" folder missing, including "MainMenu.nib", which seems to be responsible for the menu.

Part of the updater log that is probably related to the problem:
-------------------------------------------------------
FINISH ADD Contents/MacOS/res/MainMenu.nib/classes.nib
backup_discard: backup file doesn't exist: Contents/MacOS/res/MainMenu.nib/classes.nib.moz-backup
FINISH ADD Contents/MacOS/res/MainMenu.nib/info.nib
backup_discard: backup file doesn't exist: Contents/MacOS/res/MainMenu.nib/info.nib.moz-backup
FINISH ADD Contents/MacOS/res/MainMenu.nib/keyedobjects.nib
backup_discard: backup file doesn't exist: Contents/MacOS/res/MainMenu.nib/keyedobjects.nib.moz-backup
FINISH ADD Contents/MacOS/res/cursors/arrowN.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/arrowN.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/arrowS.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/arrowS.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/colResize.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/colResize.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/help.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/help.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/rowResize.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/rowResize.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/sizeNE.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/sizeNE.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/sizeNESW.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/sizeNESW.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/sizeNS.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/sizeNS.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/sizeNW.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/sizeNW.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/sizeNWSE.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/sizeNWSE.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/sizeSE.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/sizeSE.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/sizeSW.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/sizeSW.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/spin1.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/spin1.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/spin2.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/spin2.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/spin3.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/spin3.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/spin4.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/spin4.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/vtIBeam.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/vtIBeam.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/zoomIn.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/zoomIn.tiff.moz-backup
FINISH ADD Contents/MacOS/res/cursors/zoomOut.tiff
backup_discard: backup file doesn't exist: Contents/MacOS/res/cursors/zoomOut.tiff.moz-backup
-------------------------------------------------------

It looks like there were no ".moz-backup" files created for each file there at all, but for the whole res folder ("res.moz-backup").


Steps to reproduce:
1) get a 2.1b2pre SeaMonkey build for Mac from January, 18th or older
2) use the integrated update function
3) see the menu missing


The problem is just an update problem - full new omni.jar-enabled builds itself work without problems.
Comment 1 Robert Kaiser 2011-01-31 10:37:16 PST
The fun thing is that there is no res/ folder supposed to be in builds now... does a fresh install have one?
Comment 2 Adrian Kalla [:adriank] 2011-01-31 14:15:19 PST
(In reply to comment #1)
> The fun thing is that there is no res/ folder supposed to be in builds now...
> does a fresh install have one?

A fresh install does have one. Copying it from there to an updated build which does not have the folder, fixes the problem.
Comment 3 Robert Kaiser 2011-01-31 18:28:01 PST
This sounds to me, then, like the package stuff is doing the right thing, but removed-files is removing res/ when it's not empty.

What is the list of files that are in res/ in a packaged build (and are therefore missing in the update)?
Comment 4 Robert Kaiser 2011-01-31 18:31:39 PST
Just FTR, this should block b2, as without fixing this, the updates on Mac will not work correctly.
Per analysis of comment #3, the fix should be relatively easy, i.e. similar to patterns we fixed recently in other bugs, my second paragraph in that comment is to ensure we leave behind the right things when we remove only what should be removed.
Comment 5 Justin Wood (:Callek) 2011-01-31 20:20:25 PST
(In reply to comment #3)
> What is the list of files that are in res/ in a packaged build (and are
> therefore missing in the update)?

Stefanh/Karsten, 

If you get to answer this before adriank what would be useful is a trunk build from before omnijar to a b2pre nightly...

Separately updated via normal app-(nightly)-update and one that is installed directly for latest nightly,

and do a diff of the file lists |find . > updated-file.list| and |find . > clean-install.list| and diff the two lists :-)

We can be sure to have this fixed right with that. (Otherwise I'll have 0 confidence in what I am reviewing or patching here)
Comment 6 Adrian Kalla [:adriank] 2011-02-01 02:26:07 PST
Created attachment 508702 [details]
file list from an updated build
Comment 7 Adrian Kalla [:adriank] 2011-02-01 02:28:06 PST
Created attachment 508703 [details]
file list from a clean install
Comment 8 Adrian Kalla [:adriank] 2011-02-01 06:50:48 PST
A moment ago I was able to reproduce this problem here with an 20110131 -> 20110201 (Polish) update (both are omni-enabled) - the res-folder is gone after the update. So it does not seem to be a non-omni to omni update problem only...
Comment 9 Robert Kaiser 2011-02-01 08:27:42 PST
(In reply to comment #6)
> Created attachment 508702 [details]
> file list from an updated build

The .moz-backup stuff should not be there at all, that it is indicates an error of some sort, IMHO.

(In reply to comment #7)
> Created attachment 508703 [details]
> file list from a clean install

Contents/MacOS/res/cursors
Contents/MacOS/res/MainMenu.nib

are both there, and I guess we are wrongly removing those via removed-files, with I think should be the actual error/bug here.


And yes, sure, that would affect any update since we introduced that removal, which probably came in with thew omni.jar switch.
Comment 10 Robert Kaiser 2011-02-01 09:19:43 PST
Created attachment 508786 [details] [diff] [review]
don't remove res/

This should fix the bug, I hope.
Comment 11 Justin Wood (:Callek) 2011-02-01 19:21:12 PST
Comment on attachment 508786 [details] [diff] [review]
don't remove res/

lets land this, and let adriank or another mac user RESO, and if not fixed we can certainly investigate further.

Also once this lands lets kick [another] mac nightly build, just to let the testing happen almost immediately.
Comment 12 Robert Kaiser 2011-02-02 04:09:29 PST
Landed as http://hg.mozilla.org/comm-central/rev/507ba1c3e1b3 and triggered another nightly (the previous regular one from today hasn't finished yet, though).
Comment 13 Adrian Kalla [:adriank] 2011-02-02 09:17:12 PST
after updating from 20110201 to 20110202, it looks to be fixed now. thanks

Note You need to log in before you can comment on or make changes to this bug.