Closed Bug 630354 Opened 9 years ago Closed 4 years ago

Only one of the two methodShapeChange signatures bumps thrashCount

Categories

(Core :: JavaScript Engine, defect)

Other Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 684505

People

(Reporter: jorendorff, Unassigned)

Details

See the source--or bug 629968 comments 21-26.
The summary is not complete -- "in all cases, and then doing so would unbrand the global object, after which disaster" makes it too long, as a summary, though :-/.

More thoughts in a bit, once I have decongested.

/be
Assignee: general → nobody
thrashCount was removed in https://hg.mozilla.org/mozilla-central/rev/ff51ddfdf5d1 (bug 684505)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 684505
You need to log in before you can comment on or make changes to this bug.