Status

()

defect
RESOLVED DUPLICATE of bug 600556
8 years ago
8 years ago

People

(Reporter: hurin8888, Assigned: bbondy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Build Identifier: 

this favicon does not render on firefox (4 beta 10) but it does on internet explorer and google chrome. It is saved as 4bpp, 1-bit alpha, 16 slot palette and png compression

Reproducible: Always

Steps to Reproduce:
1.open favicon in firefox (see attachments)
2.nothing displays
3.open it with ie or chrome, it displays
Actual Results:  
a blank picture at expected dimensions, without any color

Expected Results:  
a picture at expected dimensions, with the logo drawn
Component: Graphics → ImageLib
QA Contact: thebes → imagelib
(Assignee)

Comment 2

8 years ago
The referenced image is a PNG icon.  We will support PNG icons once my patch here is pushed: Bug 600556
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 600556
(Assignee)

Comment 3

8 years ago
I did verify with the patch in Bug 600556 and the reference image looks right.
(Assignee)

Updated

8 years ago
Assignee: nobody → netzen
You need to log in before you can comment on or make changes to this bug.