the effect of max-width

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: tapio.markula, Assigned: clayton)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Sorry, the width control works:
I have this css:

html {background-color:#603;border:none;margin:0;padding:0px;}
body.mielipide {max-width:600px;margin: auto;margin-bottom:30px}

The problem of Mozilla is that it renders the page totally white.
Opera render the area, which is outside the max-width as #603 = at the background-color, which belongs to the HTML element. In my mind Opera does it
right. Do you disagree?

Opera understands the max-width as ABSOLUTE concerning the whole element, not only the width of the content area like Mozilla Gecko.
In fact this matter is not exactly defined.

Damned all different interpretaions!
- Opera and Mozilla has different interpretation of 'viewport'
- how to render borders to some form elements: http://www.nic.fi/~tapio1/Teaching/Taustat.html
- how to handle are outside the max-width property.
Created attachment 20798 [details]
Testcase using max-width on body
The attached testcase worksforme with linux build 2000-12-05-08.  The white area
is 600px wide, and the rest of the page has background #603.

Resolving worksforme.  Reporter, feel free to reopen if you try a recent nightly
build and still see the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
*** Bug 63030 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.