Closed Bug 630519 Opened 10 years ago Closed 9 years ago

Crash [@ nsINode::GetUserData(nsAString_internal const&) ]

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 614347
Tracking Status
blocking2.0 --- final+

People

(Reporter: scoobidiver, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [fixed by bug 614347?][hardblocker])

Crash Data

It is a new crash signature. Crashes appeared in 4.0b10pre/20110113 and reappeared in 4.0b10pre/20110130.
It is #74 top crasher in 4.0b11pre over the last 3 days.

Signature	nsINode::GetUserData(nsAString_internal const&)
UUID	98b44fbc-121c-454d-aac8-576052110131
Time 	2011-01-31 20:13:44.741276
Uptime	258
Last Crash	328 seconds (5.5 minutes) before submission
Install Age	14350 seconds (4.0 hours) since version was first installed.
Product	Firefox
Version	4.0b11pre
Build ID	20110131064745
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	AuthenticAMD family 15 model 107 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 0622, AdapterDriverVersion: 8.17.12.6658

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsINode::GetUserData 	obj-firefox/dist/include/nsINode.h:1061
1 	xul.dll 	nsNode3Tearoff::GetUserData 	content/base/src/nsGenericElement.cpp:1166
2 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
3 	xul.dll 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1593
4 	mozjs.dll 	CallCompiler::generateNativeStub 	js/src/methodjit/MonoIC.cpp:667
5 	mozjs.dll 	js::mjit::ic::NativeCall 	js/src/methodjit/MonoIC.cpp:874
6 		@0x4fc46c1 	
7 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:748
8 	mozjs.dll 	CheckStackAndEnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:774
9 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:791
10 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:654
11 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:737
12 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:858
13 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5076
14 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1701
15 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:588
16 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
17 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
18 	xul.dll 	nsContentPolicy::CheckPolicy 	content/base/src/nsContentPolicy.cpp:157
19 	xul.dll 	nsContentPolicy::ShouldLoad 	content/base/src/nsContentPolicy.cpp:218
20 	xul.dll 	NS_CheckContentLoadPolicy 	obj-firefox/dist/include/nsContentPolicyUtils.h:221
21 	xul.dll 	nsContentUtils::CanLoadImage 	content/base/src/nsContentUtils.cpp:2454
22 	xul.dll 	nsImageLoadingContent::LoadImage 	content/base/src/nsImageLoadingContent.cpp:685
23 	xul.dll 	nsImageLoadingContent::LoadImage 	content/base/src/nsImageLoadingContent.cpp:624
24 	xul.dll 	nsHTMLImageElement::SetAttr 	
25 	xul.dll 	nsGenericHTMLElement::SetAttr 	content/html/content/src/nsGenericHTMLElement.h:166
26 	xul.dll 	nsGenericHTMLElement::SetAttrHelper 	content/html/content/src/nsGenericHTMLElement.cpp:2083
27 	xul.dll 	nsHTMLImageElement::SetSrc 	content/html/content/src/nsHTMLImageElement.cpp:221
28 	xul.dll 	nsIDOMHTMLImageElement_SetSrc 	obj-firefox/js/src/xpconnect/src/dom_quickstubs.cpp:17444
29 	mozjs.dll 	js::Shape::set 	js/src/jsscopeinlines.h:275
30 	mozjs.dll 	js_NativeSet 	js/src/jsobj.cpp:5208
...

More reports at:
https://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=nsINode%3A%3AGetUserData%28nsAString_internal%20const%26%29
Depends on: 614347
(In reply to comment #0)
> It is a new crash signature. Crashes appeared in 4.0b10pre/20110113 and
> reappeared in 4.0b10pre/20110130.


So sounds like a bug bug 624549 revealed. Didn't cause, but revealed, I think.
FWIW

I crashed like http://crash-stats.mozilla.com/report/index/bp-d0a3418d-9fd5-4b12-91b3-ba7972110201 on Mozilla/5.0 (Windows NT 6.0; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre ID:20110201030339

I was dragging/zooming on the Google Map at http://www.opentopia.com/map.php?country_code=MX&searchname=zacatecas when the crash occurred.

Tried again but can't replicate =(
It is #13 top crasher in 4.0b11.
not seen much on trunk but up to 400 crashes per day on betas with 2million+ users.

date     total    breakdown by build
         crashes  count build, count build, ...

20110210 209  	204 4.0b112011020314, 
        		3 4.0b12pre2011020903, 	1 4.0b12pre2011021003, 
        		1 4.0b12pre2011020803, 
20110211 229  	226 4.0b112011020314, 
        		2 4.0b12pre2011021003, 	1 4.0b12pre2011021103, 
20110212 211  	208 4.0b112011020314, 
        		1 4.0b12pre2011021203, 	1 4.0b12pre2011021103, 
        		1 4.0b12pre2011020403, 
20110213 266  	262 4.0b112011020314, 
        		2 4.0b12pre2011021303, 	2 4.0b12pre2011021203, 
20110214 274  	266 4.0b112011020314, 
        		5 4.0b12pre2011021303, 	1 4.0b12pre2011021403, 
        		1 4.0b12pre2011021103, 	1 4.0b12pre2011020603, 
20110215 255  	250 4.0b112011020314, 
        		3 4.0b12pre2011021503, 	1 4.0b12pre2011021303, 
        		1 4.0b12pre2011021003, 
20110216 320  	319 4.0b112011020314, 
        		1 4.0b12pre2011021603, 
20110217 317  	313 4.0b112011020314, 
        		2 4.0b12pre2011021603, 	1 4.0b12pre2011021503, 
        		1 4.0b12pre2011021303, 
20110218 307  	303 4.0b112011020314, 
        		3 4.0b12pre2011021603, 	1 4.0b12pre2011021003, 
20110219 320  	319 4.0b112011020314, 
        		1 4.0b12pre2011021603, 
20110220 364  	363 4.0b112011020314, 
        		1 4.0b12pre2011021603, 
20110221 419 4.0b112011020314 	419 ,
blocking2.0: --- → ?
Status: NEW → RESOLVED
blocking2.0: ? → final+
Closed: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: [fixed by bug 614347?][hardblocker]
Duplicate of bug: 614347
Crash Signature: [@ nsINode::GetUserData(nsAString_internal const&) ]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.