buidbot should be able to reboot a machine if a step times out and cannot kill the step

RESOLVED DUPLICATE of bug 626486

Status

Release Engineering
General
P3
normal
RESOLVED DUPLICATE of bug 626486
7 years ago
4 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [buildmasters][buildbot])

(Reporter)

Description

7 years ago
We know that to get a slave out of hung state most of the time is to reboot the machine.

We can't reach the reboot step because we get blocked on trying to SIGKILL (I think) but that fails or it has already exited.

Any thoughts on how to do this?
The ProcessAlreadyExited() error is a subcase of this bug, pretty sure that's already filed.

Updated

7 years ago
Priority: -- → P3
Whiteboard: [buildmasters][buildbot]
(Reporter)

Comment 2

7 years ago
Let's say this got fixed in bug 626486.

If it happens again we will have to revisit.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 626486
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.