Add support to about:memory for getting data from the child process

RESOLVED DUPLICATE of bug 633305

Status

Fennec Graveyard
General
RESOLVED DUPLICATE of bug 633305
7 years ago
7 years ago

People

(Reporter: mfinkle, Assigned: dougt)

Tracking

Trunk
x86
Mac OS X

Details

We should add a section to the about:memory that lists the data from the child process

Comment 1

7 years ago
This is going to be interesting.  about:memory uses nsIMemoryReporter, which just has a couple accessors that return values on demand.  Since the numbers come from the content process, we can't just synchronously ask for them.  Therefore, we either:

* update the parent reporters at regular intervals, when we won't actually care about them 99% of the time
* introduce a "priming" phase into the memory reporter manager, such that nsMemoryReporterManager::EnumerateReporters actually traverses the array and pokes each reporter in case it needs to get ready.  Then we race to see if we can get a value from content just in time to show it!

Any other ideas are welcome, too.
Assignee: nobody → doug.turner
tracking-fennec: ? → 2.0-

Comment 2

7 years ago
The other bug has a patch, so duping forward.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 633305
You need to log in before you can comment on or make changes to this bug.