Can't add the current page to the bookmarks. Crash!!

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
Bookmarks & History
P1
blocker
VERIFIED FIXED
18 years ago
7 years ago

People

(Reporter: Jason M'Sadoques, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash, pp})

Trunk
mozilla0.9
PowerPC
Mac OS X
crash, pp

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i586; en-US; m18) Gecko/20001215
BuildID:    2000121521

When you use either the keyboard keys or the menu item, mozilla doesn't respond
to adding a bookmark.

Reproducible: Sometimes
Steps to Reproduce:
Go to some random page and either press ctrl-D, or alt-D to add a bookmark, or
use the menu item.

Actual Results:  Nothing

Expected Results:  Added the current page to the list of bookmarks.

I'm running RedHat Linux 6.2 (2.2.14-5.0) on a custom computer AMD K6-2 500mhz,
128mb ram, 6.3G on 3 HDDs. Glibc 2.1.

Comment 1

18 years ago
since there is no real reprodicable testcase, going to mark this worksforme. I
tried on several sites and it worked each time.  This is using a cvs pull from
22 Dec (today). If you get a new build and stil can reproduce this, please reopen.

thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 2

18 years ago
I have managed to verify this one Win98.

There did not appear to be any consistancy about sites I could not bookmark. I
couldn't bookmark this page, but when I opened it in a new window I could
bookmark not problem.

I suspect the issue could be related to resources. I am currently on
system 32% free, user 51% free, GDI 32% free
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

18 years ago
worksforme again, was an old build the win98 reporter was using
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 4

18 years ago
Reopening bug as I am once again able to verify this, using build 2000122520 (a 
week old, and a slow week development wise too).

By pure chance I happened to have the JavaScript console open at the time I 
failed to bookmark (I was trying to bookmark MozillaZine Build Comments if it 
matters) and I got this error:

Error: focusedWindow has no properties
Source File: chrome://communicator/content/contentAreaUtils.js
Line: 121
Col: 0
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

18 years ago
Ok.  In testing I see two categories of bug here: one where the add bookmark
action isn't triggered and another where the action is triggered and fails.

The first case can be reproduced two ways:
  First, with focus in any text field, <ctrl>+D won't work.  Instead, a single
character is deleted. This is intentional (although i think it causes confusion
when accelerators are redefined).
  Second, sometimes the top mozilla window will lose focus while appearing to
have it - the window decoration indicates focus, but no accelerators work (e.g.
alt menu accels, ctrl <anything>). bug 32349 is one instance of this type of bug.

The second case's symptom is indicated by the focusedWindow error noted by Ian
Thomas.  I am attaching a potential workaround for that, but I need someone else
to look at it for correctness.

Marking as new...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

18 years ago
Created attachment 21724 [details] [diff] [review]
default Charset for cases where focusedWindow isn't valid

Comment 7

18 years ago
CC'ing Jag, he might be interested by this. Please note that focusedWindow is 
always null (see bug 56063).

Comment 8

18 years ago
seeing on linux commercial build 2001-02-05-08-mtrunk
this just apppeared over the weekend....until now this has worked fine
adding keyword smoketest and upgrading to blocker.
Severity: normal → blocker
Keywords: smoketest
I believe this is a makefile problem that has been fixed. Works on windows 
because the correct resources were being built. Blizzard has checked in a fix for 
unix. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
verified fixed on linux commercial build 2001-02-06-06-mtrunk
Status: RESOLVED → VERIFIED
seen on Mac commercial build 2001-02-06-10-mtrunk

crashing when attempting to add bookmark
Status: VERIFIED → REOPENED
Keywords: crash
OS: Linux → MacOS X
Hardware: PC → Macintosh
Resolution: FIXED → ---
Summary: Can't add the current page to the bookmarks. → Can't add the current page to the bookmarks. Crash!!

Comment 12

18 years ago
*** Bug 67841 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
see comment about RDF in dup bug 67841

Comment 14

18 years ago
Ben says opening the tree shouldn't cause him grief, so I'm going to open the
tree due to the moz 0.8 freeze at midnight.  If this bug is still around
post-freeze, we'll hold the tree again then.

Comment 15

18 years ago
this is a high profile crasher and a platform parity issue.  A fix for 0.8 would
be great.
Whiteboard: critical to mozilla 0.9

Updated

18 years ago
Whiteboard: critical to mozilla 0.9 → critical to mozilla 0.8

Comment 16

18 years ago
 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  1F0D5528  
  0F0CF6C0    PPC  1F0BD424  main+00130
  0F0CF660    PPC  1F0BC764  main1(int, char**, nsISupports*)+007F8
  0F0CF3C0    PPC  1E5CCB3C  nsAppShellService::Run()+00018
  0F0CF380    PPC  1D3A7210  nsAppShell::Run()+00048
  0F0CF330    PPC  1D3A795C  nsMacMessagePump::DoMessagePump()+0003C
  0F0CF2E0    PPC  1D3A7F70  nsMacMessagePump::DispatchEvent(int,
EventRecord*)+00170
  0F0CF290    PPC  1D3BE828  Repeater::DoRepeaters(const EventRecord&)+00030
  0F0CF250    PPC  1D3844B8  nsMacNSPREventQueueHandler::RepeatAction(const
EventRecord&)+000
0C
  0F0CF210    PPC  1D3845D0  nsMacNSPREventQueueHandler::ProcessPLEventQueue()+000B0
  0F0CF1A0    PPC  1E627C34  nsEventQueueImpl::ProcessPendingEvents()+000E4
  0F0CF130    PPC  1E627C34  nsEventQueueImpl::ProcessPendingEvents()+000E4
  0F0CF0C0    PPC  1E627B88  nsEventQueueImpl::ProcessPendingEvents()+00038
  0F0CF050    PPC  1E689ED4  PL_ProcessPendingEvents+00078
  0F0CF010    PPC  1E68A058  PL_HandleEvent+00020
  0F0CEFD0    PPC  1D977FF4  nsStreamObserverEvent::HandlePLEvent(PLEvent*)+00020
  0F0CEF90    PPC  1D978278  nsOnStopRequestEvent::HandleEvent()+000B8
  0F0CEF30    PPC  1D96A3A8 
OnStopRequest__12nsJARChannelFP10nsIChannelP11nsISupportsUiPCw+0
0074
  0F0CEEE0    PPC  1D8F6F60 
RemoveChannel__11nsLoadGroupFP10nsIChannelP11nsISupportsUiPCw+00
104
  0F0CEE60    PPC  1D4E6230 
OnStopRequest__15nsDocLoaderImplFP10nsIChannelP11nsISupportsUiPC
w+000D4
  0F0CEE10    PPC  1D4E64E8  nsDocLoaderImpl::DocLoaderIsEmpty(unsigned int)+00108
  0F0CEDB0    PPC  1D4E6788  nsDocLoaderImpl::doStopDocumentLoad(nsIChannel*,
unsigned int)+0
0068
  0F0CED60    PPC  1D4E7B74  nsDocLoaderImpl::FireOnStateChange(nsIWebProgress*,
nsIRequest*,
 int, unsigned int)+001B8
  0F0CEC70    PPC  1E5C1864  nsWebShellWindow::OnStateChange(nsIWebProgress*,
nsIRequest*, in
t, unsigned int)+00328
  0F0CEAC0    PPC  1E5C06EC  nsWebShellWindow::DynamicLoadMenus(nsIDOMDocument*,
nsIWidget*)+
000FC
  0F0CE910    PPC  1E5C1E30  nsWebShellWindow::FindNamedDOMNode(const nsString&,
nsIDOMNode*,
 int&, int)+00178
  0F0CE810    PPC  1E5C1E30  nsWebShellWindow::FindNamedDOMNode(const nsString&,
nsIDOMNode*,
 int&, int)+00178
  0F0CE710    PPC  1E5C1E30  nsWebShellWindow::FindNamedDOMNode(const nsString&,
nsIDOMNode*,
 int&, int)+00178
  0F0CE610    PPC  1E5C1E30  nsWebShellWindow::FindNamedDOMNode(const nsString&,
nsIDOMNode*,
 int&, int)+00178
  0F0CE510    PPC  1E5C1E30  nsWebShellWindow::FindNamedDOMNode(const nsString&,
nsIDOMNode*,
 int&, int)+00178
  0F0CE410    PPC  1E5C1E30  nsWebShellWindow::FindNamedDOMNode(const nsString&,
nsIDOMNode*,
 int&, int)+00178
  0F0CE310    PPC  1E5C1E30  nsWebShellWindow::FindNamedDOMNode(const nsString&,
nsIDOMNode*,
 int&, int)+00178
  0F0CE210    PPC  1E5C1E30  nsWebShellWindow::FindNamedDOMNode(const nsString&,
nsIDOMNode*,
 int&, int)+00178
  0F0CE110    PPC  1E5C1E30  nsWebShellWindow::FindNamedDOMNode(const nsString&,
nsIDOMNode*,
 int&, int)+00178
  0F0CE010    PPC  1E5C1E04  nsWebShellWindow::FindNamedDOMNode(const nsString&,
nsIDOMNode*,
 int&, int)+0014C
  0F0CDF10    PPC  1D69DAEC  NSGetModule+052C4
  0F0CDEC0    PPC  1D6A287C  NSGetModule+0A054
  0F0CDE80    PPC  1D6A8508  NSGetModule+0FCE0
  0F0CDE10    PPC  1D657F9C  nsXULDocument::CreateContents(nsIContent*)+00098
  0F0CDDC0    PPC  1D6BC92C  NSGetModule+24104
  0F0CDD70    PPC  1D6C2A98 
nsXULTemplateBuilder::CreateTemplateAndContainerContents(nsICont
ent*, nsIContent**, int*)+000A4
  0F0CDC50    PPC  1D6C3444 
nsXULTemplateBuilder::CreateTemplateContents(nsIContent*, const 
nsString&, nsIContent**, int*)+00418
  0F0CDAF0    PPC  1D6C0460 
nsXULTemplateBuilder::BuildContentFromTemplate(nsIContent*, nsIC
ontent*, nsIContent*, int, nsIRDFResource*, int, Match*, nsIContent**, int*)+010B8
  0F0CD170    PPC  1D6BEE68  NSGetModule+26640
  0F0CD040    PPC  1D6BEAB0  NSGetModule+26288
  0F0CCE90    PPC  1D6BF030  NSGetModule+26808
  0F0CCD60    PPC  1D6B3B40  NSGetModule+1B318

Comment 17

18 years ago
Might also want to consider the return stack, as that will give function names
rather than module positions
Here's how I can crash it every time on linux.

o Open the Manage Bookmarks menu
o Select a regular bookmark by clicking on it.
o Use the File Bookmark menu/button to try and put the bookmark into a leaf node.

As soon as I pass the first node it falls over.  As soon as I can get a debug
build I'll get a stack trace.

Comment 19

18 years ago
The crash that blizzard describes is due to 
nsBindingManager::GetNestedInsertionPoint() blowing the stack. This is bug 
#67990 which hyatt has a one liner fix for.
Well, let's get that fix in.

Also, are you saying that my crash is different than the crash that is described
in this bug?
i have a workaround that will do for .8
Status: REOPENED → ASSIGNED
Created attachment 24828 [details] [diff] [review]
simple patch to disable this dialog for mac. should prevent crash for .8

Comment 23

18 years ago
r=cmanske

Comment 24

18 years ago
r=blake
(I don't think the toLowerCase() is really necessary...)

Comment 25

18 years ago
sr=alecf

Comment 26

18 years ago
a=asa for checking this in for 0.8.  This bug should stay open since the problem
is not fixed.  Either that or a new bug should be filed to restore the dialog on
Mac. 
removing smoketest, ccing waterson. 
Keywords: smoketest

Updated

18 years ago
Keywords: mozilla0.9, pp
Whiteboard: critical to mozilla 0.8
I had problems with bookmarks too. Tried to bookmark this page with
2001-02-28-21 on Linux. Pressed Ctrl+D and the dialog appeared. But when I tried
to bookmark again either using keyboard or menu, nothing happened.
Unfortunatel I can't reproduce this reliably. Two pages from five tested.

Updated

18 years ago
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9

Comment 30

18 years ago
Marking nsbeta1+, p1, mozilla0.9
I believe this is due to the tree widget that contained the template generated
content being hidden by default. The dialog has been changed so that the tree
widget is always visible now. This probably fixes the crash. Marking fixed. 
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 32

18 years ago
This is working for me in 031211 mac mozilla build on OS9.  The Add Bookmark
window displays, allows me to specify a name and location and does not crash
when I hit OK.  Woo-Hoo!

Comment 33

18 years ago
VERIFIED Fixed with 2001042608 builds
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.