Make about:home search field re-use autocomplete values from the old page

RESOLVED FIXED in Firefox 4.0b12

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

({regression})

unspecified
Firefox 4.0b12
Points:
---

Firefox Tracking Flags

(blocking2.0 .x+)

Details

(Whiteboard: [about-home])

Attachments

(1 attachment)

Assignee

Description

9 years ago
Connor suggested to set name="q" on the search field in about:home to reuse old autocomplete data. Losing that data is indeed a regression from what we have in FX3.6

While we investigate bug 612453 (making decent and sexy autocomplete code could not be that trivial) this sounds like a really simple fix that could make the release.
Assignee

Comment 1

9 years ago
asking softblocking because sounds like a simple, safe and sensible thing to do if we can't make a good suggest code in time.
blocking2.0: --- → ?
Doesn't block, but if it's that simple, a patch would be approved.
blocking2.0: ? → .x
Assignee

Updated

9 years ago
Whiteboard: [about-home]
Assignee

Comment 3

9 years ago
Posted patch patch v1.0Splinter Review
Trying to split up the reviews burden, mconnor suggested this and I think he can review (And eveventually approve?) it :)
Asking approval at the same time since the patch is trivial.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #510596 - Flags: review?(mconnor)
Attachment #510596 - Flags: approval2.0?
Comment on attachment 510596 [details] [diff] [review]
patch v1.0

I am not a current browser peer, but I can approve it once I see a review!
Attachment #510596 - Flags: review?(mconnor) → review?(dolske)
Attachment #510596 - Flags: review?(dolske)
Attachment #510596 - Flags: review+
Attachment #510596 - Flags: approval2.0?
Attachment #510596 - Flags: approval2.0+
Assignee

Comment 5

9 years ago
http://hg.mozilla.org/mozilla-central/rev/4215b25a76c2
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b12
You need to log in before you can comment on or make changes to this bug.