js1k demo no longer working

RESOLVED DUPLICATE of bug 623437

Status

()

Core
Canvas: 2D
RESOLVED DUPLICATE of bug 623437
8 years ago
3 years ago

People

(Reporter: gal, Unassigned)

Tracking

({qawanted, regression})

unspecified
x86
All
qawanted, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(URL)

(Reporter)

Description

8 years ago
http://js1k.com/2010-first/demo/635

This worked the last time I looked at it a few weeks ago.
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
(Reporter)

Updated

8 years ago
Keywords: qawanted
(Reporter)

Comment 1

8 years ago
Could we get some help with a regression range here?
(Reporter)

Comment 2

8 years ago
(also works in webkit-based browsers)
Confirmed.

Old rendering stays around instead of being cleared. Could be explained by the background being rendered as transparent instead of opaque.
(Reporter)

Updated

8 years ago
Keywords: regression, regressionwindow-wanted
Note: confirmed on linux, so it's not OS-specific.
OS: Mac OS X → All
Happens also without GL layers. Not a GL layers bug.
(Reporter)

Comment 8

8 years ago
bug 617319 sticks out. I remember that causing problems before. bjacob?
Seems likely to be a problem similar to the one in bug 623437
Demo has:

  for ($ in C = c.getContext('2d')) C[$[J = X = Y = 0] + ($[6] || '')] = C[$];

So yeah, this is the arc/arcTo thing just like in bug 623437.
So, how can we fix that?

Is that a bug in the demo or on our side?
(Reporter)

Comment 12

8 years ago
That depends on your definition of "bug". The demo relies on a particular enumeration order, and we recently changed that order. None of this is specified. But it seems like a regression to me.
So this demo only ever worked on Firefox?

I mean, if the enumeration order is unspecified, presumably other browsers don't use the same?
It's unspecified, but that doesn't mean it's not interoperable... to a degree.  At least in terms of whether arc or arcTo comes first.
This is basically bug 623437; let's take the discussion there.
(Reporter)

Comment 17

8 years ago
This works in every browser but us, and it used to work in FF a month ago.
Why wasn't this duped to bug 623437?

/be
Because we hadn't decided whether to fix or evang.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 623437
Bug 623437 comment 16 seemed to have no effect, and bug 623437 comment 17 gave me no hope. What made "we" decide to fix rather than evang?

I'm all in favor of fixing, in case it isn't obvious. Not that that mattered at the time of the bug 623437 comment 16 and 17 exchange! :-|

/be
> What made "we" decide to fix rather than evang?

The fact that I though of a small safe fix.  At least that certainly swayed _my_ decision!
To be clear, of a small safe fix for the particular ordering change the demos really really depend on not happening, not other ordering changes we also introduced.
Cool -- you rock!

/be
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.