About Mozilla overlaps on to the other elements in the home page

RESOLVED FIXED in Firefox 9

Status

()

Firefox
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Srinivas, Assigned: int3)

Tracking

Trunk
Firefox 9
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4b11][about-home])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110202 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110202 Firefox/4.0b12pre

About Mozilla overlaps on to the other elements in the home page while resizing the Fx window

Reproducible: Always

Steps to Reproduce:
1.Open Fx and navigate to about:home
2.Resize the firefox window to 340*315 pixel size
3.Observe the link About Mozilla and the botton
Actual Results:  
Link "About Mozilla" overlaps on the button and the button overlaps on the "Preferences" making it unable to click
(Reporter)

Updated

6 years ago
Whiteboard: [4b11]
(Reporter)

Comment 1

6 years ago
Created attachment 509379 [details]
Screenshot

Comment 2

6 years ago
Able to reproduce on Win 7 and Mac 10.6 using 
Mozilla/5.0 (Windows NT 6.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11 
and
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110203 Firefox/4.0b12pre 

Setting the resolution to NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

6 years ago
Regression window:
Last good build: http://hg.mozilla.org/mozilla-central/rev/94a51a3b64d4 

First bad build: http://hg.mozilla.org/mozilla-central/rev/336d5906cb0f

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=94a51a3b64d4 &tochange=336d5906cb0f

Updated

6 years ago
Whiteboard: [4b11] → [4b11][about-home]
I guess we could want a min-height on the page.
(Assignee)

Comment 5

6 years ago
Created attachment 549637 [details] [diff] [review]
Patch v1

This hides the 'About Mozilla' link when the screen gets too small. I also tweaked things such that the 'About Mozilla' link doesn't overlap the 'Restore Previous Session' button for a ~470px window.
(Assignee)

Updated

6 years ago
Attachment #549637 - Flags: review?(gavin.sharp)
Attachment #549637 - Flags: review?(gavin.sharp) → review?(mak77)
(Assignee)

Updated

6 years ago
OS: Windows XP → All
(Assignee)

Updated

6 years ago
Attachment #549637 - Flags: review?(mak77) → review?(gavin.sharp)
Attachment #549637 - Flags: review?(gavin.sharp) → review?(mak77)

Updated

6 years ago
Assignee: nobody → jezreel
Status: NEW → ASSIGNED
Hardware: x86 → All
Comment on attachment 549637 [details] [diff] [review]
Patch v1

Review of attachment 549637 [details] [diff] [review]:
-----------------------------------------------------------------

the patch looks good, but trying to resize the page, the jump due to the searchbox height change becomes too much visible.
Thus I suggest that in addition to this we also replace:

@media all and (max-height: 450px) {
  #searchContainer { height: 30% }
}

with:

@media all and (max-height: 500px) {
  #searchContainer { height: 25% }
}

@media all and (max-height: 370px) {
  #searchContainer { height: 30% }
}

for a smoother balancing on resize (and to balance your top change at 500px)
Attachment #549637 - Flags: review?(mak77) → review+

Updated

6 years ago
Duplicate of this bug: 676028
(Assignee)

Comment 8

6 years ago
Created attachment 550269 [details] [diff] [review]
Patch v2

Updated patch with suggestion.

I noticed the jumpiness too while testing; I'm not sure this change reduces it by much, but it does make things look more balanced.
Attachment #549637 - Attachment is obsolete: true
(Assignee)

Updated

6 years ago
Keywords: checkin-needed

Comment 9

6 years ago
In my queue, pushing to inbound once confirmed everything builds locally.
Keywords: checkin-needed
Version: unspecified → Trunk
s/everything/everything else/

Also, for future patches, can you check your hgrc is set up like here:
blog.bonardo.net/2010/06/22/so-youre-about-to-use-checkin-needed
...since the current patch was missing the |# HG changeset patch| line, which causes hg qimport to break and put the author in the commit field etc.

Thanks :-)
http://hg.mozilla.org/integration/mozilla-inbound/rev/c76345028fa7
Target Milestone: --- → Firefox 9
http://hg.mozilla.org/mozilla-central/rev/c76345028fa7
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.