Overlay with status messages is misaligned with aero glass in non-maximized windows

VERIFIED FIXED in Firefox 4.0b12

Status

()

Firefox
Theme
--
trivial
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Terepin, Assigned: dao)

Tracking

({polish})

unspecified
Firefox 4.0b12
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre

See screenshot.

Reproducible: Always
(Reporter)

Comment 1

7 years ago
Created attachment 509382 [details]
Screenshot
(Reporter)

Updated

7 years ago
Blocks: 628654
Keywords: polish
(Assignee)

Updated

7 years ago
Component: General → Theme
QA Contact: general → theme
Summary: Overlay with status messages is misaligned → Overlay with status messages is misaligned with aero glass in non-maximized windows
(Assignee)

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

7 years ago
Assignee: nobody → dao
(Assignee)

Comment 2

7 years ago
Created attachment 510261 [details] [diff] [review]
patch
Attachment #510261 - Flags: review?(gavin.sharp)
(Assignee)

Updated

7 years ago
Attachment #510261 - Flags: review?(felipc)
What other style rules makes this necessary? I don't really understand what the comment refers to.
(Assignee)

Comment 4

7 years ago
This: http://hg.mozilla.org/mozilla-central/annotate/9d810f5ea61c/browser/themes/winstripe/browser/browser-aero.css#l139
Attachment #510261 - Flags: review?(gavin.sharp)
Attachment #510261 - Flags: review+
Attachment #510261 - Flags: approval2.0+
Won't this override http://mxr.mozilla.org/mozilla-central/source/browser/themes/winstripe/browser/browser.css#2272 ?

Most of the CSS uses quotes for the attribute matching, but I see some more recent code without them. Is this a trend?
(Assignee)

Comment 6

7 years ago
(In reply to comment #5)
> Won't this override
> http://mxr.mozilla.org/mozilla-central/source/browser/themes/winstripe/browser/browser.css#2272
> ?

I don't think so, but will double-check.

> Most of the CSS uses quotes for the attribute matching, but I see some more
> recent code without them. Is this a trend?

Yes! :)
(Assignee)

Comment 7

7 years ago
Created attachment 510410 [details] [diff] [review]
patch v2

Felipe was right, the previous patch was overriding the status panel's horizontal margin towards the center of the content area (which, when hovered, causes the panel to move to the other side). I was expecting the opposite (i.e. that the existing margin would override the 1px margin when needed).

.statuspanel-inner never has a padding, so there's no such interference.
Attachment #510261 - Attachment is obsolete: true
Attachment #510410 - Flags: review?(gavin.sharp)
Attachment #510261 - Flags: review?(felipc)
Comment on attachment 510410 [details] [diff] [review]
patch v2

Should you use the same :not(inFullscreen) selector as the border style, to avoid the same flicker?
(Assignee)

Comment 9

7 years ago
Created attachment 510416 [details] [diff] [review]
patch v3

Can't hurt to add it. If you go fullscreen while a page is loading and focus on the status panel, I think you can see it move by one pixel.
Attachment #510416 - Flags: review?(gavin.sharp)
Comment on attachment 510416 [details] [diff] [review]
patch v3

one of those "left"s wants to be a "right"
Attachment #510416 - Flags: review?(gavin.sharp)
Attachment #510416 - Flags: review+
Attachment #510416 - Flags: approval2.0+
Attachment #510410 - Attachment is obsolete: true
Attachment #510410 - Flags: review?(gavin.sharp)
(Assignee)

Updated

7 years ago
Duplicate of this bug: 632032
(Assignee)

Comment 12

7 years ago
Created attachment 510437 [details] [diff] [review]
for check-in
Attachment #510416 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
(Assignee)

Updated

7 years ago
Duplicate of this bug: 632249
http://hg.mozilla.org/mozilla-central/rev/dd1474517009
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b12

Comment 15

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110216 Firefox/4.0b12pre

Verified issue and it's no longer present.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.