Memory not being freed after tabs closed, FF uses 2GB ram with 1 open tab

RESOLVED DUPLICATE of bug 631494

Status

()

--
critical
RESOLVED DUPLICATE of bug 631494
8 years ago
8 years ago

People

(Reporter: raquacontact, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

I tend to do my daily feeds browsing in a way that I have live bookmarks and choose option to "Open All in Tabs". Then I go through tabs and close them one after other. Sometimes this is a lot of tabs, like here:
http://www.androidpit.com/en/android/market/apps/subscribe-new/atom.xml

I use extension "Load Tabs Progressively" to not load everything at once. (Why is this not a default functionality?)

Anyway, after opening a lot of tabs and then closing them, memory is not freed. It does not make a difference whether they are closed one by one or all at once. 

I was able to reproduce this with clean new profile, no extensions enabled and plugins disabled. 

Reproducible: Always

Steps to Reproduce:
1. Bookmark 2-3 live feeds that have a lot of items. For example http://www.androidpit.com/en/android/market/apps/subscribe-new/atom.xml 
But the "Latest News" live bookmark which you get with default empty profile works too. 
2. Do "Open All in Tabs" on one live bookmark and wait until all is loaded.
3. Do "Close All Other Tabs"
4. Repeat with other live bookmarks feed.  
5. Memory usage keeps growing, memory is not freed. 

Actual Results:  
Ofter loading the aforementioned live bookmark, closing and then repeating it for the "Latest News" my FF memory usage has been almost 2GB.

Expected Results:  
Garbage collector should free memory when tabs are closed. Even waiting for a hour did not reduce memory footprint. 

I had similar issue with the 3.6.12 or 3.6.13 (not sure) version. That was the impulse to switch to 4b9 and now I experience it with 4b10.

FF eventually crashes (when reaches 2GB?)

Updated

8 years ago
Version: unspecified → Trunk

Comment 1

8 years ago
Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110209 Firefox/4.0b12pre

Can reproduce issue using the default "Latest Headlines" rss feed.

One tab opened: ~650MB RAM memory occupied
All RSS feeds opened: ~1.5GB RAM memory occupied
All RSS fees closed - one empty tab opened: ~1.1GB RAM memory occupied
Closing FF: ~650MB RAM memory occupied

It can be clearly observed that there are approximately an extra 600MB of RAM that are occupied although, FF is displaying only an empty tab.

Issue is related to bug 631494 - Massive memory leak with Adblock Plus 1.3.3 installed. Setting as duplicate
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 631494
You need to log in before you can comment on or make changes to this bug.