Closed Bug 631794 Opened 9 years ago Closed 9 years ago

After click Flash movie, I cannot type any text in any text field in content or in chrome

Categories

(Core :: Plug-ins, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: alice0775, Assigned: jimm)

References

Details

(Keywords: regression)

Build Identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre ID:20110204030345

See http://forums.mozillazine.org/viewtopic.php?p=10388627#p10388627

After click Flash movie, I cannot type any text in SearchBar/LocationBar


Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open Flash movie ( Ex. http://www.youtube.com/watch?v=EK2tWVj6lXw )
3. Click on the search bar; the caret appears in the search bar
4. Click the video; now the flash plugin takes focus
5. Now click the search bar again; it should focus the search bar again obviously
6. Start typing; nothing happens


Actual Results:
 I cannot type any text.

Expected Results:
 I can type text.

Regression window
Works:
http://hg.mozilla.org/mozilla-central/rev/019e47cc11e2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110203 Firefox/4.0b12pre ID:20110203165107
Fails:
http://hg.mozilla.org/mozilla-central/rev/ed958cdc8396
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110203 Firefox/4.0b12pre ID:20110203201757
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=019e47cc11e2&tochange=ed958cdc8396
blocking2.0: --- → ?
Component: DOM: Events → Plug-ins
QA Contact: events → plugins
*It does not happen if OOPP disabled on Windows build.
*It happens regardless of the enable/disable of hardware accelerator.
*It does not happen on Linux build.
Ho hum. This should block.
Assignee: nobody → jmathies
This is not just our UI textfields like search and address, any in-content text forms are broken as well.  This is a pretty serious regression and seems worse than the bug whose fix caused this. If we don't have a quick and safe fix, should we back out the BBC iPlayer fullscreen fix?
Summary: After click Flash movie, I cannot type any text in SearchBar/LocationBar → After click Flash movie, I cannot type any text in any text field in content or in chrome
(In reply to comment #3)
> This is not just our UI textfields like search and address, any in-content text
> forms are broken as well.  This is a pretty serious regression and seems worse
> than the bug whose fix caused this. If we don't have a quick and safe fix,
> should we back out the BBC iPlayer fullscreen fix?

I've been looking at this and don't see a simple fix I can land this weekend. So I think I'll back it for now.
blocking2.0: ? → ---
Not sure if it's related or not, but I also get this behaviour when viewing PDFs (Adobe Reader X). That predates the checkin of the iPlayer patch.
I cannot reproduce any more after backed out bug 628872.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110207 Firefox/4.0b12pre ID:20110207030345
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.