Last Comment Bug 631900 - Port |Bug 555547 - A command of placesContextMenu is carried out for a wrong bookmark item| to SeaMonkey
: Port |Bug 555547 - A command of placesContextMenu is carried out for a wrong ...
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- major (vote)
: seamonkey2.1b3
Assigned To: Serge Gautherie (:sgautherie)
:
Mentors:
Depends on: 555547
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-06 06:28 PST by Serge Gautherie (:sgautherie)
Modified: 2011-02-10 17:46 PST (History)
2 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
(Av1) Just copy application code [Checked in: Comment 5] (3.63 KB, patch)
2011-02-07 05:13 PST, Serge Gautherie (:sgautherie)
iann_bugzilla: review+
Details | Diff | Review
(Bv1) Copy browser_555547.js, Sort test lists (4.74 KB, patch)
2011-02-07 05:14 PST, Serge Gautherie (:sgautherie)
no flags Details | Diff | Review
(Cv1-WP1) Adapt browser_555547.js (1.59 KB, patch)
2011-02-07 05:17 PST, Serge Gautherie (:sgautherie)
iann_bugzilla: feedback-
Details | Diff | Review

Description Serge Gautherie (:sgautherie) 2011-02-06 06:28:24 PST

    
Comment 1 Serge Gautherie (:sgautherie) 2011-02-07 05:13:12 PST
Created attachment 510254 [details] [diff] [review]
(Av1) Just copy application code
[Checked in: Comment 5]
Comment 2 Serge Gautherie (:sgautherie) 2011-02-07 05:14:33 PST
Created attachment 510255 [details] [diff] [review]
(Bv1) Copy browser_555547.js, Sort test lists

Bare copy from Firefox, can't succeed as is.
Comment 3 Serge Gautherie (:sgautherie) 2011-02-07 05:17:59 PST
Created attachment 510256 [details] [diff] [review]
(Cv1-WP1) Adapt browser_555547.js

I tried to adapt this test, but I don't know this code and porting toggleSidebar() seems like a requirement from some other bug (port).

helpwanted to port this test, unless we can just live without it (ftb).
Comment 4 Philip Chee 2011-02-08 07:12:21 PST
To replace toggleSidebar() you would need something like:
http://mxr.mozilla.org/comm-central/source/suite/browser/navigator.js?mark=1239-1247#1239

1239       if (sidebar_is_hidden())
1240         SidebarShowHide();
1241 
1242       if (sidebar_is_collapsed())
1243         SidebarExpandCollapse();
1244 
1245       var searchPanel = document.getElementById("urn:sidebar:panel:search");
1246       if (searchPanel)
1247         SidebarSelectPanel(searchPanel, true, true); // lives in sidebarOverlay.js
Comment 5 Serge Gautherie (:sgautherie) 2011-02-08 08:05:48 PST
Comment on attachment 510254 [details] [diff] [review]
(Av1) Just copy application code
[Checked in: Comment 5]

http://hg.mozilla.org/comm-central/rev/7bda34f6086b
Comment 6 Serge Gautherie (:sgautherie) 2011-02-09 03:35:40 PST
Let's call this fixed ftb, even though it's still 'in‑testsuite=?'.
Comment 7 Ian Neal 2011-02-10 17:46:40 PST
Comment on attachment 510256 [details] [diff] [review]
(Cv1-WP1) Adapt browser_555547.js

This probably needs to wait until Firefox sidebar API is ported to SeaMonkey - if there's not a bug for that already there probably needs to be one.

Note You need to log in before you can comment on or make changes to this bug.