[Options Windows] Homepage text field is not RTL enabled

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: prasad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4b11])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre
Build Identifier: 

Options->General: Homepage text field is not RTL enabled

Reproducible: Always

Steps to Reproduce:
Installed from nightly Hebrew verion:
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre

1.Open Tools->Options
2.Click inside the Home Page text field
3.Start typing
Actual Results:  
Input comes in LTR mode

Expected Results:  
Input should be RTL for RTL languages

RTL direction is retained in other text fields like:
Option->Advanced->Network:
- Manual proxy confguration text fields, and
- Autoproxy configuration URL

Where as noticed that General:Homepage text field is in LTR
(Reporter)

Updated

8 years ago
Whiteboard: [4b11]
This is by design -- it's wrong that some fields used for URLs are still RTL, and this is bug 219070 and its dependencies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.