Saving / opening PDF document does not work

RESOLVED INVALID

Status

Camino Graveyard
OS Integration
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Hauke Fath, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en; rv:1.9.2.15pre) Gecko/20110203 Camino/2.1a2pre (like Firefox/3.6.15pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en; rv:1.9.2.15pre) Gecko/20110203 Camino/2.1a2pre (like Firefox/3.6.15pre)

When you click on a link to a PDF document, Camino 2.x and older open a dialog that lets you either save the PDF, or pick an application to open it.

-current Camino (nightly from 2011-02-03 here) opens a dialog that requests me to find Acrobat Reader. The name appears to be hard-coded, as I cannot select e.g. Skim, my PDF reader of choice. When I exit the dialog with Cancel, either because I'd rather save the PDF, or because I'd like it opened in a different viewer, I am left with an empty browser tab. Even a 'Reload' won't do anything.

So, (a) -current Camino lost the option to save a PDF to disk, and (b) it has a filter for Acrobat Reader hard-coded in the "search for application" dialog. Both are a serious regression against release Camini.


Reproducible: Always

Steps to Reproduce:
1. Install a nightly Camino snapshot
2. On a page that links a PDF document, click on link

Actual Results:  
You get a dialog asking you to find Acrobat Reader. E.g. Apple Preview or Skim won't do.

Expected Results:  
A dialog allowing you to specify what should happen with the PDF.


Ask me whether to save the PDF to disk, or open it with an application I get to select. Camino 2's behaviour was just fine here.
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

7 years ago
Created attachment 510249 [details]
File selector dialog screenshot
(Reporter)

Comment 2

7 years ago
As you can see from the screenshot, only Acrobat Reader 7 is acceptable, Acrobat Reader 9 won't do.

To add insult to injury, after you agree to Camino's preference, _nothing_ happens. Plus, the setting doesn't stick - you'll have to go through the same pointless routine next time you want to (and cannot) download a PDF. 

Workaround: Ctrl-click and selecting "Save as..." from the context menu works fine.

Comment 3

7 years ago
> Camino 2.x and older open a dialog that lets you either save the PDF,
> or pick an application to open it.

I'm not aware of anything in any version of Camino that would offer you an option to open a file directly with an application. And when I click on the link in this report, it downloads the PDF.

Are you using a third-party download manager, or some other runtime hack that modifies Camino's behavior?

Alternately, do you have the pref to auto-open downloads set, and if so is this dialog you are seeing coming up *after* the file is downloaded?
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> > Camino 2.x and older open a dialog that lets you either save the PDF,
> > or pick an application to open it.
>
> I'm not aware of anything in any version of Camino that would offer you an
> option to open a file directly with an application.

Nor was I - until yesterday.

> And when I click on the
> link in this report, it downloads the PDF.

Cool. Mine (version see above) doesn't.

> Are you using a third-party download manager, or some other runtime hack that
> modifies Camino's behavior?

No. Nothing relevant set in about:config, either.

> Alternately, do you have the pref to auto-open downloads set,

Nope, "false".

> and if so is this
> dialog you are seeing coming up *after* the file is downloaded?

Nothing gets downloaded, no.
(Reporter)

Comment 5

7 years ago
There is an "Adobe Acrobat and Reader Plug-in" installed, though, version 7.0.9. Maybe that is the culprit?

"Help::Installed Plug-Ins" only gives me a list of plugins, unfortunately, and no way of selectively disabling them.

Comment 6

7 years ago
Wow, interesting. The Acrobat Reader plugin has always been WebKit-specific before, so if it's showing up in Camino they must have released an NPAPI plugin (which would certainly explain this behavior). Did you recently install or update an Adobe product?

There's no UI for disabling individual plugins, but there is a new hidden pref. If you set the hidden preference camino.disabled_plugin_names to "Adobe Acrobat" it should disable this plugin, so we can be 100% sure that's the cause.
(Reporter)

Comment 7

7 years ago
(In reply to comment #6)
> Did you recently install or update an Adobe product?

Not after I installed the Camino nightly snapshot. The Acrobat Reader 9 was last updated in mid-2009, according to the timestamps.
 
> There's no UI for disabling individual plugins, but there is a new hidden pref.
> If you set the hidden preference camino.disabled_plugin_names to "Adobe
> Acrobat" it should disable this plugin, so we can be 100% sure that's the
> cause.

Yep, that fixes it - the "Acrobat Reader Plugin" entry is gone, and Camino is back to the old behaviour, saving the PDF straight away. Cool, thanks!

Looks like current Camino is picking up something it's not meant to, since Camino v2 doesn't...

Comment 8

7 years ago
> Looks like current Camino is picking up something it's not meant to

Camino can only load NPAPI plugins. If this is an NPAPI plugin installed in your Internet Plug-Ins folder, then Camino is meant to load it. If it's not an NPAPI plugin, it's completely and utterly impossible for the entry you are seeing to show up in about:plugins.

I don't know why Camino 2.0 wouldn't have picked it up (have you actually verified that if you launch Camino 2.0.6 right now, it doesn't?), nor do I know where this plugin came from--I've never heard of it--but given that it's there, Camino is doing the right thing, and the behavior you are seeing is a bug in the plugin, which you should report to Adobe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
> I don't know why Camino 2.0 wouldn't have picked it up (have you actually
> verified that if you launch Camino 2.0.6 right now, it doesn't?), nor do I know
> where this plugin came from--I've never heard of it--but given that it's there,
> Camino is doing the right thing, and the behavior you are seeing is a bug in
> the plugin, which you should report to Adobe.

I cleared "camino.disabled_plugin_names", started Camino 2.0.6, and "Help::Installed Plug-Ins" does not display the mysterious Adobe Acrobat Reader plug-in. A click on the example link loads the PDF file straight away.
(Reporter)

Comment 10

7 years ago
Switching back to the latest snapshot ("Version 2.1a2pre (1.9.2.15pre 20110207001622)") lists the Adobe plugin again, and indeed I get asked for the location of Acrobat Reader when I click the above sample URL.

The plugin is indeed fairly old

% ls -l /Library/Internet\ Plug-Ins/AdobePDFViewer.plugin/
total 0
drwxrwxr-x   6 hauke  admin  204 May  2  2009 Contents
%

Comment 11

7 years ago
Huh, I have no idea why Camino 2.0 failed to load it. Still, comment 8 stands.
(Reporter)

Comment 12

7 years ago
It was the Acrobat Reader plugin for Safari which came with Reader 7. When I move it out of the way, or have it replaced with Reader 9's plugin, current Camino is fine. 

FTR: All things being equal, I think current Camino is doing something differently. The Reader 7 plugin has been around on my machine since the Camino 1.5.x days without ever getting in the way.

Comment 13

7 years ago
> I think current Camino is doing something differently.

Clearly it is, given what you saw with side-by-side 2.0 and 2.1 testing. If 2.0 wasn't loading an installed NPAPI plugin, that was a bug in Gecko 1.9.0, which apparently was fixed in Gecko 1.9.2.
You need to log in before you can comment on or make changes to this bug.