Last Comment Bug 632026 - Reflect.parse: `typeof(0?0:a)` and `typeof a` parse the same, but are different programs
: Reflect.parse: `typeof(0?0:a)` and `typeof a` parse the same, but are differe...
Status: RESOLVED FIXED
reflect-parse fixed-in-tracemonkey
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: All All
: -- normal (vote)
: ---
Assigned To: general
:
:
Mentors:
Depends on: 571617
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-07 07:27 PST by Jason Orendorff [:jorendorff]
Modified: 2011-06-27 15:15 PDT (History)
2 users (show)
dherman: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jason Orendorff [:jorendorff] 2011-02-07 07:27:29 PST
js> typeof(0?0:a)
ReferenceError: a is not defined
js> typeof a
"undefined"

js> Reflect.parse("typeof(0?0:a)", {loc:0}).toSource() === Reflect.parse("typeof a", {loc:0}).toSource()
true
Comment 1 Dave Herman [:dherman] 2011-06-07 00:07:37 PDT
I believe this bug should just go away with the patch for bug 571617.

Dave
Comment 2 Dave Herman [:dherman] 2011-06-23 00:20:03 PDT
Fixed automatically by fix for bug 571617. Landed a test:

http://hg.mozilla.org/tracemonkey/rev/2c1422971722

Dave
Comment 3 Chris Leary [:cdleary] (not checking bugmail) 2011-06-27 11:40:13 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/2c1422971722
Note: not marking as fixed because fixed-in-tracemonkey is not present on the whiteboard.

Note You need to log in before you can comment on or make changes to this bug.