Testopia installation fails

UNCONFIRMED
Assigned to

Status

Testopia
General
UNCONFIRMED
7 years ago
3 years ago

People

(Reporter: Marceli, Assigned: Greg Hendricks)

Tracking

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 (CK-IBM) Firefox/3.6.13
Build Identifier: Testopia 2.4 / Bugzilla 3.6.4

Hello everyone,

I've just installed Bugzilla 3.6.4 in my Red Hat and it works fine.
I tried to install Testopia 2.4 following the instructions in https://wiki.mozilla.org/Testopia:README#Installation_on_Linux
After running checksetup.pl I see this message:

"Checking Testopia setup ...
Can't use an undefined value as a HASH reference at ./extensions/Testopia/Extension.pm line 1274"

I can't see the links for Testopia in Bugzilla either.

Reproducible: Always

Comment 1

6 years ago
Can you reproduce this in v2.5 ?

Comment 2

5 years ago
Hi,

I installed vanilla bugzilla v4.2.5 and tried
to setup Testopia. After untar in the bugzilla
base directory and installing the missing perl cpan
packages, i run checksetup.pl  and end with the
following error:

Checking Testopia setup ...
Can't use an undefined value as a HASH reference at ./extensions/Testopia/Extension.pm line 1425.

The line itself contains the following code:
        $dbh->bz_drop_fk('test_cases', 'priority_id') if $dbh->bz_column_info('test_cases','priority_id')->{REFERENCES}->{DELETE} eq 'CASCADE';


If I comment out the code, I get (of course - the database is not correct) another error:
Checking Testopia setup ...
Not a reference at Bugzilla/DB/Schema.pm line 2778.

How can I fix this installation issue ?

regards
Danny

Comment 3

5 years ago
> I installed vanilla bugzilla v4.2.5 
It's not a vanilla bugzilla - sorry. It's v4.2.5 upgrade von 3.0.x some times ago.

Comment 4

3 years ago
I have installed Testopia 2.5 to the Bugzilla version 5.0, but the Testopia does not show up on the Bugzilla.

Can you please let me know the solution for this
You need to log in before you can comment on or make changes to this bug.