Last Comment Bug 632233 - XULBrowserWindow.onLocationChange looks for a "disablefastfind" attribute in all content documents before ruling them out because their URI scheme isn't "about" or "chrome"
: XULBrowserWindow.onLocationChange looks for a "disablefastfind" attribute in ...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on:
Blocks: 569342
  Show dependency treegraph
 
Reported: 2011-02-07 16:08 PST by Dão Gottwald [:dao]
Modified: 2012-01-05 07:00 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.43 KB, patch)
2012-01-02 06:56 PST, Dão Gottwald [:dao]
gavin.sharp: review+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2011-02-07 16:08:48 PST

    
Comment 1 :Margaret Leibovic 2011-02-07 16:56:50 PST
My patch in bug 569342 performs the checks in a different order, so Gavin must have commented on it IRL, but I forget what the reasoning behind the change was.
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-02-28 00:47:10 PST
Why does this matter? I wouldn't expect there to be a significant difference between docElt.getAttribute vs. the two schemeIs calls.
Comment 3 Dão Gottwald [:dao] 2012-01-02 06:56:27 PST
Created attachment 585284 [details] [diff] [review]
patch

The discussion in bug 384412 reminded me of this again. Even if it may end up not mattering, we should, on principle, access content as late as possible.
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2012-01-05 07:00:31 PST
https://hg.mozilla.org/mozilla-central/rev/dd994bf80fc0

Note You need to log in before you can comment on or make changes to this bug.