Handle non-finite values for clearRect per spec

RESOLVED FIXED in mozilla5

Status

()

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Ms2ger, Assigned: Ms2ger)

Tracking

(Blocks 1 bug, {dev-doc-complete, html5})

Trunk
mozilla5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Posted patch Patch v1 (obsolete) — Splinter Review
No description provided.
Flags: in-testsuite+
Attachment #510676 - Flags: review?(Olli.Pettay)
Comment on attachment 510676 [details] [diff] [review]
Patch v1

So why doesn't .clearRect throw?
Seems like canvas API is all but consistent when to throw and when not.
Assignee

Comment 2

8 years ago
I apparently was wrong before. The spec silently ignores all non-finite arguments, except when creating CanvasGradient and ImageData objects, and it throws for negative radii, which, I suppose, would be caused by a bogus calculation.
Attachment #510676 - Flags: review?(Olli.Pettay) → review+
Assignee

Updated

8 years ago
Depends on: post2.0
Whiteboard: [needs landing]
Assignee

Updated

8 years ago
Keywords: checkin-needed
Whiteboard: [needs landing]
Assignee

Comment 3

8 years ago
Attachment #510676 - Attachment is obsolete: true
http://hg.mozilla.org/mozilla-central/rev/69bd065b7fa8
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
No longer depends on: post2.0
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: fixed-in-cedar
Target Milestone: --- → mozilla2.2
You need to log in before you can comment on or make changes to this bug.