Last Comment Bug 632482 - Handle non-finite values for arcTo per spec
: Handle non-finite values for arcTo per spec
Status: VERIFIED FIXED
: dev-doc-complete, html5
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: :Ms2ger
:
Mentors:
Depends on:
Blocks: 622842
  Show dependency treegraph
 
Reported: 2011-02-08 11:18 PST by :Ms2ger
Modified: 2011-08-31 04:50 PDT (History)
2 users (show)
Ms2ger: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.38 KB, patch)
2011-02-08 11:18 PST, :Ms2ger
jst: review+
Details | Diff | Review

Description :Ms2ger 2011-02-08 11:18:01 PST
Created attachment 510693 [details] [diff] [review]
Patch v1
Comment 2 Simona B [:simonab] 2011-08-29 06:19:29 PDT
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0

I was trying to see if this is fixed for Fx7 since the Target Milestone is set on "mozilla 7", and I used "test_canvas.html" from the repo. Can anyone tell me what is expected to be seen for the test_canvad.html, or is there another testcase that can be used to verify the fix? 

Thanks!
Comment 3 :Ms2ger 2011-08-30 13:08:34 PDT
<http://w3c-test.org/html/tests/submission/PhilipTaylor/canvas/2d.path.arcTo.nonfinite.html> should have a green background and say "* Passed".
Comment 4 Simona B [:simonab] 2011-08-31 04:50:54 PDT
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0

Verified issue on Win XP, Win 7, Ubuntu 11.04 and Mac OS X 10.6 using the following test case (the background is green and the result is "Passed"): 
http://w3c-test.org/html/tests/submission/PhilipTaylor/canvas/2d.path.arcTo.nonfinite.html

Setting resolution to VERIFIED FIXED.

Thanks Ms2ger!!!

Note You need to log in before you can comment on or make changes to this bug.