Crash incidents return 500 Internal Server Error

VERIFIED FIXED in 1.7.7

Status

Socorro
General
--
major
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: stephend, Assigned: ryansnyder)

Tracking

({regression})

Trunk
1.7.7
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 510819 [details]
Screenshot

STR:

1. Click on any stacktrace/signature, such as https://crash-stats.stage.mozilla.com/report/list?range_value=2&range_unit=weeks&signature=GraphWalker%3CscanVisitor%3E%3A%3ADoWalk%28nsDeque%26%29&version=Firefox%3A4.0b8
2. Now, under the "Date" column, click on any incident

Actual:

[15:53:55.038] GET https://crash-stats.stage.mozilla.com/report/index/74126f21-61df-4f2b-add2-5c24e2110205 [HTTP/1.1 500 Internal Server Error 2980ms]

"Error

Something bad happened. It's not you, it's me.

Please submit a Bugzilla ticket describing what happened, and please include the URL for this page."

Comment 1

7 years ago
Jabba, can you pull the Kohana logs and then reassign this to Ryan or myself?
Assignee: nobody → jdow

Comment 2

7 years ago
Apprently we have access to Kohana logs.
Assignee: jdow → ryan
There is nothing in the Kohana logs on stage for this error.

Are any crash reports accessible on stage?   I haven't found any yet.
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> There is nothing in the Kohana logs on stage for this error.
> 
> Are any crash reports accessible on stage?   I haven't found any yet.

I haven't found one that works, no :-(
I can't dig into this until we get bug 630948 resolved.
Blocks: 630948
Duplicate of this bug: 635048
After committing bug 635097 I noticed a couple errors in the log that may be causing this issue:

2011-02-17 17:45:18 -08:00 --- error: [5xx Error] File: application/models/common.php; Line: 333; Message: Undefined index:  reason

Committing a fix.  Displaying now on stage per:

https://crash-stats.stage.mozilla.com/report/index/a19e24a4-84db-40f9-a4a4-866e12110216

==

Sending        application/models/common.php
Transmitting file data .
Committed revision 2939.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

7 years ago
Thx, Ryan; also verified on https://crash-stats.stage.mozilla.com/report/index/63f6051c-5e14-4bd0-8500-d22552110217.
Status: RESOLVED → VERIFIED
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.