Scrolling gesture on Alps touchpad zooms instead of scrolling

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Reporter)

Description

8 years ago
This is a regression from bug 593372. By default, my touchpad now zooms when I attempt to scroll. I have an HP dv4t with Windows 7 x64 with an Alps touchpad. Changing the ui.elantech_gesture_hack.enabled pref from -1 to 0 fixes the problem.
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
Keywords: regression
Elantech registry entries weren't present on Ryan's laptop, so that isn't the cause.

Comment 2

8 years ago
I'm seeing this with my Logitech mouse on my desktop with the latest hourly (http://hg.mozilla.org/mozilla-central/rev/fa1a4b6abff0).  Attempting to scroll the page with my scrollwheel is causing the zoom level to change.  I have the Logitech SetPoint software installed.  This is all on Windows 7 x64.
Doug: does setting ui.elantech_gesture_hack.enabled to 0 fix it?

If so, can you debug to find out why IsObsoleteElantechDriver is returning true?

Comment 4

8 years ago
(In reply to comment #3)
> Doug: does setting ui.elantech_gesture_hack.enabled to 0 fix it?
> 
> If so, can you debug to find out why IsObsoleteElantechDriver is returning
> true?

No, setting ui.elantech_gesture_hacks.enabled to 0 does not have any effect (and I did restart Fx just to be sure).
fixed by backout
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.