[skiplist] Add pthread_mutex_lock to prefixSignatureRegEx

RESOLVED FIXED in 3

Status

Socorro
Infra
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: ted, Assigned: laura)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-], URL)

(Reporter)

Description

7 years ago
pthread_mutex_lock is showing up as the #2 mac crash over the past week, but it's just a system library function with a few different root causes underneath it. Specifically, bug 582466 was a Mozilla bug that got fixed, and bug 628914 and bug 564089 are plugin bugs. We should add pthread_mutex_lock to prefixSignatureRegEx to differentiate these signatures.
Component: Socorro → General
Product: Webtools → Socorro
(Assignee)

Updated

6 years ago
Component: General → Infra

Comment 1

6 years ago
This signature is still around, and the bug has all the info in comment #0 and summary, so this should be ready for being done. Laura?
Summary: Add pthread_mutex_lock to prefixSignatureRegEx → [skiplist] Add pthread_mutex_lock to prefixSignatureRegEx

Updated

6 years ago
Duplicate of this bug: 695260
(Assignee)

Comment 3

6 years ago
In https://github.com/lauraxt/socorro/commit/26c9a101bb8f713910e32e181f76f3422decd365
Assignee: nobody → laura
Target Milestone: --- → 3

Comment 4

6 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/26c9a101bb8f713910e32e181f76f3422decd365
Fixes bug 632788, Add pthread_mutex_lock to the prefix skiplist

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Whiteboard: [qa-]

Comment 5

6 years ago
Commit pushed to stage at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/6375b062bd8fb1d247b55cd8e79a06e9141624bf
Fixes bug 632788, Add pthread_mutex_lock to the prefix skiplist

Updated

6 years ago
Blocks: 564089

Updated

6 years ago
Blocks: 628914

Comment 6

6 years ago
Commit pushed to https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/6375b062bd8fb1d247b55cd8e79a06e9141624bf
Fixes bug 632788, Add pthread_mutex_lock to the prefix skiplist

Comment 7

6 years ago
Commit pushed to v3-branch at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/6375b062bd8fb1d247b55cd8e79a06e9141624bf
Fixes bug 632788, Add pthread_mutex_lock to the prefix skiplist
You need to log in before you can comment on or make changes to this bug.