input text is not selectable in the Web Console via Ctrl+a

RESOLVED DUPLICATE of bug 623749

Status

DevTools
General
RESOLVED DUPLICATE of bug 623749
8 years ago
a month ago

People

(Reporter: AlexLakatos, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Input text is not selectable in the Web Console via Ctrl+a, just via mouse click and drag.

Steps To Reproduce:
1.Open Web Console (CTRL+SHIFT+K)
2.Type console.log("STR");
3.Press CTRL+A

Actual Results:
3.The cursor is at the begining of the line and the text is not selected

Expected Results:
3.The cursor is at the begining of the line and the text is selected

Note: 
This happens on Windows XP, Windows 7 and Ubuntu 10.4. 
This works fine on Mac OS X 10.6 with CMD+A

Comment 1

8 years ago
control-a is console keybinding for 'beginning of line'
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

8 years ago
CTRL+A works under Windows/Linux as "Select All". It's corespondent in Mac OS X is CMD+A.

So if CTRL+A is keybinded in Web Console under Windows/Linux why isn't CMD+A on Mac OS X?

And what is the shortcut on Windows/Linux for "Select All"?
they're emacs-style keybindings.

Comment 4

8 years ago
(In reply to comment #3)
> they're emacs-style keybindings.

Correction: its really unix-style keybindings. Both Mac and Linux work that way in the terminal.

Comment 5

8 years ago
Changing resolution to reflect this is actually a dupe of bug 623749. I think we're going to keep seeing these complaints, and that bug has more discussion on this.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 623749

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.