Crash [@ libSystem.B.dylib@0x4160 ] mainly close to startup and with 1password

RESOLVED DUPLICATE of bug 616518

Status

()

--
critical
RESOLVED DUPLICATE of bug 616518
8 years ago
3 years ago

People

(Reporter: scoobidiver, Assigned: kev)

Tracking

({crash, topcrash})

unspecified
x86
Mac OS X
crash, topcrash
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [blocklist?][hardblocker], crash signature)

(Reporter)

Description

8 years ago
It is #2 top crasher in 4.0b11.

Signature	libSystem.B.dylib@0x4160
UUID	d9bf9f3a-1e10-4aa7-afbc-ed81c2110208
Time 	2011-02-08 09:19:55.307065
Uptime	12
Last Crash	19 seconds before submission
Install Age	196 seconds (3.3 minutes) since version was first installed.
Product	Firefox
Version	4.0b11
Build ID	20110203140743
Branch	2.0
OS	Mac OS X
OS Version	10.6.6 10J567
CPU	amd64
CPU Info	family 6 model 23 stepping 6
Crash Reason	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash Address	0x0
User Comments	the app won't launch
App Notes 	Renderers: 0x24200,0x20400

Frame 	Module 	Signature [Expand] 	Source
0 	libSystem.B.dylib 	libSystem.B.dylib@0x4160 	
1 	libosxform_xpcom.dylib 	libosxform_xpcom.dylib@0xd62de 	
2 	libosxform_xpcom.dylib 	libosxform_xpcom.dylib@0x4b6f2 	
3 	XUL 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_x86_64_unix.cpp:208
4 	XUL 	XPCConvert::JSObject2NativeInterface 	js/src/xpconnect/src/xpcconvert.cpp:1528
5 	XUL 	XPCConvert::JSData2Native 	js/src/xpconnect/src/xpcconvert.cpp:1088
6 	XUL 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:3071
7 	XUL 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1593
8 	XUL 	js::Interpret 	js/src/jscntxtinlines.h:697
9 	XUL 	js::Invoke 	js/src/jsinterp.cpp:661
10 	XUL 	js::ExternalInvoke 	js/src/jsinterp.cpp:862
11 	XUL 	JS_CallFunctionValue 	js/src/jsapi.cpp:5053
12 	XUL 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2008
13 	XUL 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:9105
14 	XUL 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:9450
15 	XUL 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:425
16 	XUL 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:517
17 	XUL 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:633
18 	XUL 	NS_ProcessPendingEvents_P 	nsThreadUtils.cpp:200
19 	XUL 	nsBaseAppShell::NativeEventCallback 	widget/src/xpwidgets/nsBaseAppShell.cpp:132
20 	XUL 	nsAppShell::ProcessGeckoEvents 	widget/src/cocoa/nsAppShell.mm:399
21 	CoreFoundation 	CoreFoundation@0x4e400 	
22 	CoreFoundation 	CoreFoundation@0x4c5f8 

Here are corelations with extensions:
  libSystem.B.dylib@0x4160|EXC_BAD_ACCESS / KERN_INVALID_ADDRESS (79 crashes)
     85% (67/79) vs.  10% (261/2526) firefox4@1password.com
          1% (1/79) vs.   0% (1/2526) 3.5.1.BETA-2
          8% (6/79) vs.   2% (54/2526) 3.5.3
          9% (7/79) vs.   4% (96/2526) 3.5.4
          4% (3/79) vs.   0% (3/2526) 3.5.4.BETA-2
          1% (1/79) vs.   0% (1/2526) 3.5.4.BETA-3
          3% (2/79) vs.   0% (4/2526) 3.5.4.BETA-5
          3% (2/79) vs.   0% (3/2526) 3.5.4.BETA-6
         10% (8/79) vs.   1% (13/2526) 3.5.5.BETA-1
         47% (37/79) vs.   2% (39/2526) 3.5.5.BETA-2
          0% (0/79) vs.   1% (31/2526) 3.5.5.BETA-3

More reports at:
https://crash-stats.mozilla.com/report/list?product=Firefox&platform=mac&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=libSystem.B.dylib%400x4160
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
Keywords: topcrash

Comment 1

8 years ago
Related to bug 616518 the #1 crasher.
Renominating due to increase in frequency. Feels like we should blocklist the older version.

Adding to the hardblocking list for final so that we make a call.
blocking2.0: ? → final+
Whiteboard: [blocklist?][hardblocker]
(Reporter)

Updated

8 years ago
Component: Extension Compatibility → Blocklisting
Product: Firefox → addons.mozilla.org
QA Contact: extension.compatibility → blocklisting
Version: Trunk → unspecified
(Reporter)

Comment 3

8 years ago
One bug to blocklist 1password is enough.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 616518

Comment 4

8 years ago
The solution for this bug may be the same as the solution for bug 616518, and the problem may be with the same third-party product, but these are different crashes as far as we know right now and thus not dupes.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

8 years ago
> these are different crashes as far as we know right now and thus not dupes.
In that case, it must be affected to the right component: XPCOM?
If this is to be blocklisted, please give the exact block range details (guid, versions, application versions, etc.)
Whiteboard: [blocklist?][hardblocker] → [blocklist?][hardblocker][Needs block ranges]
(Reporter)

Updated

8 years ago
Depends on: 616518

Comment 7

8 years ago
Kev needs to supply the blocklist range.
Assignee: nobody → kev
(Reporter)

Comment 8

8 years ago
It is now only #38 top crasher in 4.0b12pre over the last week.
See bug 616518 comment 39 for the blocklist range.
From that comment:

extension: firefox3@1password.com
version: 3.5.5.* and lower
Firefox versions: 3.7a1 and higher

extension: firefox4@1password.com
version: 3.5.5.* and lower
Firefox versions: 3.7a1 and higher
Whiteboard: [blocklist?][hardblocker][Needs block ranges] → [blocklist?][hardblocker]
(Reporter)

Comment 10

8 years ago
Per comment 3 and comment 9, dupe of bug 616518.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 616518
Crash Signature: [@ libSystem.B.dylib@0x4160 ]
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.