Memory leaks, browser hangs

RESOLVED DUPLICATE of bug 631733

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 631733
7 years ago
7 years ago

People

(Reporter: Max, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b11) Gecko/20110203 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b11) Gecko/20110203 Firefox/4.0b11

When I start Fx it takes initialy about 250 MB, then this number grows by about 100 MB as tabs load (I have about 35 tabs opened). I don't usually shut down PC, so next day I see that Fx memory consumtion reaches a point at about 1GB and that's a half of all RAM installed. All numbers are taken from htop utility, RES gauge. Now trying to open a link from external application causes Fx to freeze. My system starts swapping (at least I hear HDD doing something), browser window stalls and the only way to stop this is to send SIGTERM to the application.
It seems to me that there's a memory leak or fragmentation somewhere.

Reproducible: Always

Steps to Reproduce:
1. Start Fx, load some pages in tabs.
2. Leave it, say, for 24 gours.
3. See it ate way too much RAM.
Actual Results:  
Fx memory consumption grew 2-3 times comparing to a moment when it was leaved.

Expected Results:  
Firefox shoud not consume additional memory (in such amounts) when it's not active.

In spite of my CPU architecture is 64-bit I run 32-bit version of openSuse Linux and Firefox.

Comment 1

7 years ago
Max, I am setting this as a duplicate of Bug 631733 which has been extensively discussed and which I think also covers your issue.

Feel free to changed it back to Unconfirmed if you think I am not right.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 631733
(Reporter)

Comment 2

7 years ago
Yes, looks pretty much like a duplicate. Thanks, George.
You need to log in before you can comment on or make changes to this bug.