Find in Page doubles the first characters of the searched string

RESOLVED DUPLICATE of bug 631027

Status

Firefox for Android Graveyard
General
RESOLVED DUPLICATE of bug 631027
7 years ago
7 years ago

People

(Reporter: Anna (Waverley), Unassigned)

Tracking

Trunk
ARM
Android

Details

(Reporter)

Description

7 years ago
Build Id:
Mozilla /5.0 (Android;Linux armv7l;rv:2.0b12pre) Gecko/20110210
Firefox/4.0b12pre Fennec /4.0b5pre 

Device: Motorola Droid 2 (Android 2.2)

Steps to reproduce:
1. Go to www.mozilla.org
2. Bring up the “Find in Page” toolbar and perform a search for “mozilla” (-> it works !)
3. Dismiss the find helper by tapping in the page content.
4. Bring up again the “Find in Page” toolbar. 
5. Type in "mozilla" 
    
Actual results:
After step 5, the typed in string is doubled. Actually if you are fast enough the first three characters are doubled: (e.g.: "mozmoz"). You can type only "m", wait a bit and you will see the actual result : "mm". If you delete the string from the search input (by tapping X or using Delete key from the VKB - so without dismissing the find helper) you are able to type in "mozilla".  If you type in a string that has no results on the page the characters are not doubled. Please see the following video: http://www.youtube.com/user/qaioana#p/u/0/Pq5OUvA_-gQ

Expected results: 
As you enter the string, character by character, the page scrolls along to the location of found text which is highlighted.

Note: Also you can see a big amount of checkerboards.
Note: This is not reproducing on HTC Desire (Android 2.2) only on Motorola Droid 2 (Android 2.2)
Seems like a dupe of bug 631027
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 631027
You need to log in before you can comment on or make changes to this bug.