Make background tabs have more visible hover indication

RESOLVED DUPLICATE of bug 738491

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 738491
7 years ago
6 years ago

People

(Reporter: fryn, Unassigned)

Tracking

({ux-error-prevention, ux-userfeedback})

Trunk
x86
Windows 7
ux-error-prevention, ux-userfeedback
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
From bug 624129 comment 67 :
One of the causes of confusion is that the tabs do not visually touch the top
of the screen in maximized mode. This is intentional and matches the Windows 7
theme. Note that the window close button does not touch the right side of the
screen and that that start menu orb does not touch the left side of the screen.
What makes these controls work is that a user will likely shove the cursor to
the corner of the screen and notice that the control is now glowing to indicate
that clicking at that location will activate the control, even though the the
cursor is not visually on top of the control. The background tabs currently
have a hover state, but it is too subtle. By increasing the difference in
brightness between the non-hovered and hovered states of the tabs, it becomes
much more obvious that a click or drag at the top of the screen will affect a
tab, not the window.

Comment 1

7 years ago
It's needed that you just can go to the top of the screen. Once the Windows 7 titlebar-dragging is adopted by it's user, he gets accustomed to rocket the mouse to the screen top click and drag.

Needing to look where you aim shouldn't be necessary, it destroys the aim of the titlebar-dragging. (Which is quickly demaximize the windows and drag it in place in one move and one reflex)

Current behaviour is annoying once a user is adapted to the windows behaviour.

Comment 2

7 years ago
(oh, sorry, my comment might be a bit out of context, I was looking at another bug and misinterpreted that one as being moved to here, but it seems an additional patch was moved here)
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: uiwanted
Resolution: --- → DUPLICATE
Duplicate of bug: 738491
You need to log in before you can comment on or make changes to this bug.