Open Bug 63369 Opened 21 years ago Updated 2 years ago

remove string compares against server types, switch to attributes on nsIMsgIncomingServer or nsIMsgProtocolInfo

Categories

(MailNews Core :: Backend, defect)

defect
Not set
minor

Tracking

(Not tracked)

People

(Reporter: sspitzer, Unassigned)

References

(Depends on 2 open bugs, Blocks 3 open bugs, )

Details

(Keywords: perf, student-project)

talking with racham, we notice a bunch of this in our mailnews js:

if (serverType == "nntp")
serverType != 'imap';
etc.

what we should be doing is moving the logic into the incoming server
implementations.

for example, if the point of doing the check is to determine if we should call
"perform expand" on a server on startup, we should add performExpandOnStartup as
a boolean attribute on nsIMsgIncomingServer, have the base class return
PR_FALSE, and have nsNntpIncomingServer.cpp override GetPerformExpandOnStartup()
and return PR_TRUE.

we have a ton of places where we could do this sort of cleanup, in our front end
and back end code.
change qa contact karen
Karen,
if not your area, reassign
QA Contact: esther → huang
Summary: remove string compares against server types, switch to attributes on nsIMsgIncomingServer → remove string compares against server types, switch to attributes on nsIMsgIncomingServer or nsIMsgProtocolInfo
Product: Browser → Seamonkey
Assignee: sspitzer → mail
QA Contact: huang → search
This bug is being marked EXPIRED as it has seen no activity in a very long time.

If you think that the issue reported might still be relevant, please test with a recent release of SeaMonkey and if the problem persists feel free to re-open the report. Thank you.

http://www.seamonkey-project.org/
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → EXPIRED
Bulk reopening incorrectly expired bugs - no activity does not constitute no bug - these need proper checking.
Status: RESOLVED → REOPENED
Resolution: EXPIRED → ---
Assignee: mail → nobody
QA Contact: search → message-display
Status: REOPENED → UNCONFIRMED
Ever confirmed: false
Ftr:
M.C.: "Found 18 matching lines in 7 files"
http://mxr.mozilla.org/comm-central/search?string=serverType+%28%21%7C%3D%29%5C%3D&regexp=on&find=%2Fmail%2F.*%5C.js%24
TB: "Found 4 matching lines in 3 files"
http://mxr.mozilla.org/comm-central/search?string=serverType+%28%21%7C%3D%29%5C%3D&regexp=on&find=%2Fsuite%2F.*%5C.js%24
SM: "Found 19 matching lines in 6 files"
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: MailNews: Message Display → Backend
Ever confirmed: true
Product: SeaMonkey → MailNews Core
QA Contact: message-display → backend
Hardware: x86 → All
Depends on: 181675
Depends on: 739908
This would be nice.
There are also occurences in AccountManager.js which the mxr search does not show and new are cropping up due to the new "IM" account type that lacks many capabilities (spun off to bug 739908).
Blocks: 435775
Depends on: 832034
Keywords: student-project
Keywords: perf
You need to log in before you can comment on or make changes to this bug.