Auto-hiding the Bookmarks Toolbar via userChrome.css no longer works properly - Toolbar is *empty*

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
RESOLVED WONTFIX
8 years ago
3 months ago

People

(Reporter: rkdougan, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

The Bookmarks Toolbar can be configured to auto-hide by placing the following in userChrome.css:
/* Pop-up bookmarks toolbar */
#PersonalToolbar {display: none;} #navigator-toolbox:hover >
#PersonalToolbar {display: -moz-box;}

This worked fine in Firefox 3.6 but does not work in Firefox 4.0b11. When you use the mouse to un-hide the toolbar, the toolbar does appear, but it is empty (no bookmarks are visible).

Reproducible: Always

Steps to Reproduce:
1. Make sure your Bookmarks Toolbar is enabled and contains at least 1 bookmark.
2. Close Firefox.
3. Edit userChrome.css and add these lines:
/* Pop-up bookmarks toolbar */
#PersonalToolbar {display: none;} #navigator-toolbox:hover > #PersonalToolbar {display: -moz-box;}
4. Start Firefox.
5. Hover the mouse near the Bookmarks Toolbar location.
Actual Results:  
The Bookmarks Toolbar appears, but is empty. (No bookmarks are visible).

Expected Results:  
The Bookmarks Toolbar should appear, with bookmarks visible.

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Updated

8 years ago
Summary: Auto-hiding the Bookmarks Toolbar via userChrome.css no longer works → Auto-hiding the Bookmarks Toolbar via userChrome.css no longer works properly
(Reporter)

Updated

8 years ago
Summary: Auto-hiding the Bookmarks Toolbar via userChrome.css no longer works properly → Auto-hiding the Bookmarks Toolbar via userChrome.css no longer works properly - Toolbar is *empty*
(Reporter)

Comment 1

8 years ago
Still occurring in 4.0b12
(Reporter)

Comment 2

8 years ago
Bug still occurs in 4.0 RC1
(Reporter)

Comment 3

7 years ago
Bug still occurs in 4.0 RC2

Comment 4

7 years ago
Reporter -> Is this till an issue with FF 9.0.1?

Comment 5

7 years ago
Yes, this still occurs with FF 9.0.1.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0

I can still reproduce the issue on latest Nightly (buildID: 20130806030203) and Firefox 23 RC (buildID: 20130730113002).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whilst we support userChrome.css, I'm not sure we'd make specific changes to support different features. In any case, much has changed several times since this bug was filed, and it would probably need different CSS anyway.

Therefore closing this out.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.