Keyboard shortcut to toggle add-on bar (Accel+/) doesn't work if cursor is in a text box

RESOLVED INVALID

Status

()

Firefox
General
--
minor
RESOLVED INVALID
7 years ago
3 years ago

People

(Reporter: Dave Royal, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(blocking2.0 .x+)

Details

(Whiteboard: [softblocker])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

"Ctrl+/" does not work if cursor is in URL bar - e.g. on a new blank tab. I have to click on the page area first.

Reproducible: Always

Steps to Reproduce:
1.Open new tab 'about:blank'
2.Press control /
3.
Actual Results:  
Nothing happens

Expected Results:  
Should toggle appearance of add-on bar

I have en-gb localization

Key was introduced in
https://bugzilla.mozilla.org/show_bug.cgi?id=616015

Is there a good reason for this behaviour? I often want to turn off an add-on or a userscript before loading a page, and need to go to the add-on bar to do it.

Updated

7 years ago
Version: unspecified → Trunk
Thanks for reporting. This is a bug, not by design.

I confirmed this occurs in any textbox (chrome or content), not just the URL bar.

I also confirmed that other shortcuts (ctl+k, ctl+u, etc) all work while focus is in a text box.

I don't know why only this one is ignored. Neil, do you know if this would happen at the widget level, and why?

Also, can anyone please try to confirm on Windows and Mac?
Status: UNCONFIRMED → NEW
blocking2.0: --- → final+
Ever confirmed: true
Summary: Keyboard shortcut to toggle add-on bar (Accel+/) doesn't work if cursor is in URL bar → Keyboard shortcut to toggle add-on bar (Accel+/) doesn't work if cursor is in a text box
Whiteboard: [softblocker]

Comment 2

7 years ago
On Linux, Ctrl+/ is a shortcut for Select All in entry fields.

We support this because we receive such notifications from the gtk native keybinding mechanism.
(Reporter)

Comment 3

7 years ago
Thanks for identifying the reason. A workround here on OpenSUSE 11.3 KDE4 is to add to ~/.gtkrc-2.0-kde4:

binding "fix_toggle_addon-bar" {
  unbind "<Control>slash"
}
class "GtkEntry" binding "fix_toggle_addon-bar"

That doesn't unbind ctrl+/ in multiline text areas, but it mitigates my original problem.

I also tried the latest QT build - ctrl+/ works OK there.
Should we find a different shortcut for Linux?

Or break that OS shortcut, since there's also ctrl+A for the same thing?

Or just not work in that scenario since Linux users already know that ctrl+/ is select-all when in a text box on their platform?

Comment 5

7 years ago
ctrl+A is the shortcut for 'go to start of line' when using emacs keybindings (off by default), which I assume is the reason that ctrl+/ is also used for select all.

I'd suggest either just closing this bug or changing the shortcut.
(Reporter)

Comment 6

7 years ago
I've used Linux (mostly KDE) for 10 years and never come across that key combination. I did notice that it selected the whole URL before I raised this bug, but didn't know why; I'd never looked into gtk key bindings until today! 

ctrl+A works as 'select all' here in the URL bar and in a text box - I use it often.

I think it's confusing to leave it as it is - a shortcut that sometimes works and sometimes doesn't. Many Ubuntu users are novices - they would not understand the reasons for this, or be able to do what I did to fix it (and I don't know if my config edit will stick - YaST may overwrite it).

I suggest a different shortcut - if there is one to spare.
Cannot confirm the bug for MacOS X 10.6
When I press Super+/ it toggles the addon bar (even if my cursor is on a text field)
Super = Command button in Mac
This is a pretty crappy state of affairs, even for keyboard-shortcut-land:

We have a popular Linux distro that has a default keybinding that's *redundant* and only enabled on the off-chance that a user turns on an OS-wide keybindings mode derived from a specific text editor! #fml

Does GTK have a default binding for ctrl+backslash?

Comment 9

7 years ago
Note that the keyboard handling of ctrl+/ is built into the GTK text entry widget, and isn't particular to any Linux variation.

Comment 10

7 years ago
I'm on Linux and noticed this little bug rather fast, but it's easy to notice what the problem is and it has such a simple work-around: unfocus the text box. Personally, I don't think it's worth wasting too much time on hunting for a new shortcut.

(In reply to comment #8)
> Does GTK have a default binding for ctrl+backslash?

Both ctrl+backslash and ctrl+forwardslash select all text in a box for me.
** PRODUCT DRIVERS PLEASE NOTE **

This bug is one of 7 automatically changed from blocking2.0:final+ to blocking2.0:.x during the endgame of Firefox 4 for the following reasons:

 - it was marked as a soft blocking issue without a requirement for beta coverage
blocking2.0: final+ → .x+

Comment 12

3 years ago
add-on bar no longer exists
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.