Firefox crashes when accessing $URL

VERIFIED DUPLICATE of bug 626192

Status

()

--
critical
VERIFIED DUPLICATE of bug 626192
8 years ago
8 years ago

People

(Reporter: dt-public, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

Firefox 4.0b11 crashes when accessing http://diveintohtml5.org/ with JavaScript enabled.

This also happens with b10 and b9. I've also tested the 32bit version (linux) of Firefox, where it isn't reproducable to me.

Reproducible: Always

Steps to Reproduce:
1. enable JavaScript if it isn't enabled
2. visit http://diveintohtml5.org/
3.
Actual Results:  
Crash

Expected Results:  
Don't crash ;)
Please post a stachttps://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_reportk trace/crash ID :

Comment 2

8 years ago
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report

WFM - Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110214 Firefox/4.0b12pre ID:20110214030347
Version: unspecified → Trunk
(Reporter)

Comment 3

8 years ago
fa65c71a-b83d-4e25-bd70-214e32110215

I was able to build an example to trigger it:

<!DOCTYPE html>
<html>
<head>
<script src="modernizr-1.6.min.js"></script>
</head>
<body>Foo</body>
</html>

With modernizr-1.6.min.js from http://www.modernizr.com/downloadjs/
Version: Trunk → unspecified
(Reporter)

Comment 4

8 years ago
about:crashes is nice. Setting webgl.disabled to "true" stabilizes the browser.

Comment 5

8 years ago
Signature	libGL.so.1.2@0x5b38e
UUID	fa65c71a-b83d-4e25-bd70-214e32110215
Time 	2011-02-15 03:43:12.498748
Uptime	56848
Last Crash	56851 seconds (15.8 hours) before submission
Install Age	86993 seconds (1.0 days) since version was first installed.
Product	Firefox
Version	4.0b11
Build ID	20110203141146
Branch	2.0
OS	Linux
OS Version	0.0.0 Linux 2.6.35-23-generic #41-Ubuntu SMP Wed Nov 24 11:55:36 UTC 2010 x86_64
CPU	amd64
CPU Info	family 6 model 23 stepping 10
Crash Reason	SIGSEGV
Crash Address	0x4
User Comments	
Processor Notes 	INFO: This record is a replacement for a previous record with the same uuid
EMCheckCompatibility	False
Bugzilla - Report this Crash
Related Bugs

OPEN

        Bug 626192 REOPENED firefox crashes when attempting this URL [@ libGL.so.1.2@0x5b38e ] (XF86DRIQueryVersion)

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libGL.so.1.2 	libGL.so.1.2@0x5b38e 	
1 	libGL.so.1.2 	libGL.so.1.2@0x5b528 	
2 	libGL.so.1.2 	libGL.so.1.2@0x5ae3b 	
3 	ld-2.12.1.so 	ld-2.12.1.so@0x156b4 	
4 	libc-2.12.1.so 	libc-2.12.1.so@0x38945 	
5 	libGL.so.1.2 	libGL.so.1.2@0x3a51e
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 626192
verified
hmm, what happend with my comment....
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.