intermittent failure in test_421977.js | (NS_ERROR_FAILURE) [nsIGConfService.getString] followed by failure in test_handlerService.js | true == false

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: mak, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297748186.1297749188.5701.gz

TEST-INFO | /home/cltbld/talos-slave/test/build/xpcshell/tests/browser/components/shell/test/unit/test_421977.js | running test ...
NEXT ERROR TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/browser/components/shell/test/unit/test_421977.js | test failed (with xpcshell return code: 0), see following log:
>>>>>>>
TEST-INFO | (xpcshell/head.js) | test 1 pending
TEST-UNEXPECTED-FAIL | (xpcshell/head.js) | [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIGConfService.getString]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/tests/browser/components/shell/test/unit/test_421977.js :: run_test :: line 78"  data: no]
<<<<<<<
this also comes a failure in

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/uriloader/exthandler/tests/unit/test_handlerService.js

I can't be sure but this random failure started after the push+backout of bug 633221
Summary: intermittent failure in test_421977.js | (NS_ERROR_FAILURE) [nsIGConfService.getString] → intermittent failure in test_421977.js | (NS_ERROR_FAILURE) [nsIGConfService.getString] followed by failure in test_handlerService.js | true == false
Actually started on the push, and I misstarred that one as being fixed by the backout.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297745229.1297746243.26496.gz
Rev3 Fedora 12x64 mozilla-central opt test xpcshell on 2011/02/14 20:47:09
s: talos-r3-fed64-013
it's even possible relanding bug 633221 fixed this?
I'm mostly thinking to the case the test in that bug could change some OS setting to a value persisted across restarts?
Duplicate of this bug: 648237
Whiteboard: [orange]
Resolving WFM keyword:intermittent-failure bugs last modified >3 months ago, whose whiteboard contains none of:
{random,disabled,marked,fuzzy,todo,fails,failing,annotated,time-bomb,leave open}

There will inevitably be some false positives; for that (and the bugspam) I apologise. Filter on orangewfm.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.