Fennec fails to startup on Droid Pro when the device is connected to PC via USB

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: mfinkle, Assigned: blassey)

Tracking

Trunk
All
Android

Details

Attachments

(1 attachment)

Using a current tinderbox build, I get this:

02-16 02:06:07.393  3114  3122 E AndroidRuntime: FATAL EXCEPTION: Thread-9
02-16 02:06:07.393  3114  3122 E AndroidRuntime: java.lang.NullPointerException
02-16 02:06:07.393  3114  3122 E AndroidRuntime: 	at org.mozilla.gecko.GeckoAppShell.loadGeckoLibs(GeckoAppShell.java:219)
02-16 02:06:07.393  3114  3122 E AndroidRuntime: 	at org.mozilla.gecko.GeckoApp$3.run(GeckoApp.java:210)
02-16 02:06:07.393  3114  3122 E AndroidRuntime: 	at java.lang.Thread.run(Thread.java:1096)
02-16 02:06:07.393  1259  1556 W ActivityManager:   Force finishing activity org.mozilla.fennec/.App

blocking b5 until we can figure out what is happening
Same build worked fine on Nexus One
Created attachment 512720 [details] [diff] [review]
patch
Assignee: nobody → blassey.bugs
Attachment #512720 - Flags: review?(doug.turner)
I ran a second build and still failed with this:

02-16 07:59:18.838  1259  1555 I ActivityManager: Start proc org.mozilla.fennec for activity org.mozilla.fennec/.App: pid=3494 uid=10095 gids={3003, 1015}
02-16 07:59:19.010  3494  3494 I GeckoApp: create
02-16 07:59:19.026  3494  3494 I GeckoAppJava: Checking for an update
02-16 07:59:19.026  3494  3494 W ApplicationContext: Unable to create external files directory
02-16 07:59:19.033  3494  3494 I global  : Default buffer size used in BufferedReader constructor. It would be better to be explicit if an 8k-char buffer is required.
02-16 07:59:19.033  3494  3494 I GeckoMemory: MemTotal: 488732
02-16 07:59:19.033  3494  3494 I GeckoApp: start
02-16 07:59:19.033  3494  3494 I GeckoApp: resume
02-16 07:59:19.033  3494  3502 D dalvikvm: Trying to load lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x45875400
02-16 07:59:19.041  3494  3502 D dalvikvm: Added shared lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x45875400
02-16 07:59:19.041  3494  3502 D dalvikvm: No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libmozutils.so 0x45875400, skipping init
02-16 07:59:19.041  3494  3502 W ApplicationContext: Unable to create external files directory
02-16 07:59:19.041  3494  3502 W dalvikvm: threadid=9: thread exiting with uncaught exception (group=0x400208b0)
02-16 07:59:19.041  3494  3502 E AndroidRuntime: FATAL EXCEPTION: Thread-9
02-16 07:59:19.041  3494  3502 E AndroidRuntime: java.lang.NullPointerException
02-16 07:59:19.041  3494  3502 E AndroidRuntime: 	at org.mozilla.gecko.GeckoAppShell.loadGeckoLibs(GeckoAppShell.java:219)
02-16 07:59:19.041  3494  3502 E AndroidRuntime: 	at org.mozilla.gecko.GeckoApp$3.run(GeckoApp.java:210)
02-16 07:59:19.041  3494  3502 E AndroidRuntime: 	at java.lang.Thread.run(Thread.java:1096)
02-16 07:59:19.088  3494  3502 D dalvikvm: GC_FOR_MALLOC freed 2479 objects / 193864 bytes in 46ms
02-16 07:59:19.104  1259  1410 W ActivityManager:   Force finishing activity org.mozilla.fennec/.App
(Reporter)

Updated

7 years ago
Summary: Fennec fails to startup on Droid Pro → Fennec fails to startup on Droid Pro when the device is connected to PC via USB
I saw bug 634568 and realized this was exactly what's happening for me too. Bug 634568 mentions a Droid X and I am using a Droid Pro.

The app starts up fine for me when disconnected from USB. The Nexus One worked when connected or disconnected.
(Reporter)

Updated

7 years ago
Duplicate of this bug: 634568
More notes from bug xxx:

1. This is not reproducible for other applications (e.g. Fennec RC 4.0b4)
2. This is not reproducible on HTC Desire (Android 2.2), Samsung Galaxy S
Captivate (Android 2.1 update 1) on this nightly build.
Arrrgh. I lost a battle with wget. I was using the initial build from blassey, not his updated build.

After removing all builds and wget'ing the current test build from blassey, Fennec launches fine when connected via USB.
tracking-fennec: 2.0b5+ → 2.0+
Comment on attachment 512720 [details] [diff] [review]
patch

>                 File extProf = new File (extHome, "mozilla");
>-                if (extHome.exists())
>+                if (extHome != null && extProf != null && extProf.exists())
>                     moveDir(extProf, profileDir);

We used to check if extHome.exists(), now we check if extProf.exists().  But extProf won't exist yet if we've never moved the files there, right?  It seems like we should still be checking extHome.exists().

>             File intProf = new File(intHome, "mozilla");
>-            if (intHome.exists())
>+            if (intHome != null && intProf != null && intProf.exists())
>                 moveDir(intProf, profileDir);

Same here.
Attachment #512720 - Flags: review?(doug.turner) → review?(mbrubeck)
(In reply to comment #8)
> We used to check if extHome.exists(), now we check if extProf.exists().  But
> extProf won't exist yet if we've never moved the files there, right?  It seems
> like we should still be checking extHome.exists().

Yup, that's intentional, I caught this minor issue while adding the null checks. We used to move the entire home directory, now we just move the profile, but the existence check wasn't change. It doesn't matter if the home dir exists, its the profile dir that we need to test for.
Attachment #512720 - Flags: review?(mbrubeck) → review+
OS: Linux → Android
Hardware: x86_64 → All
pushed http://hg.mozilla.org/mozilla-central/rev/972ccbb74532
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Blocks: 615519

Comment 11

7 years ago
VERIFIED FIXED on: 
Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre Fennec /4.0b5pre 

Device: Motorola Droid 2 (Android 2.2)

Comment 12

7 years ago
VERIFIED FIXED on: 
Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre Fennec /4.0b5pre 

Device: Motorola Droid 2 (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.