Closed Bug 634671 Opened 9 years ago Closed 6 years ago

Facebook's new message text box doesn't set the message box's height properly when pressing Enter in an empty message box

Categories

(Web Compatibility :: Desktop, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: ehsan, Assigned: blizzard)

Details

STR:

1. Go to the message section (you should have upgraded to the new messaging system on facebook), and create a new message.
2. Focus the textbox, and press Enter.  The height doesn't change.
3. Type "x" (or any letter).  The height doesn't change.
4. Press Enter.  The height now changes correctly.

This only happens when the first character typed is Enter.  The same bug happens in Chrome too.  Inspecting facebook under Firebug tells me that it fails to set the height CSS property at step 2 and 3.

This, when interacting with bug 631169, could make us appear more broken.  We should probably get a contact at facebook, inform them of the problem, and ask them to fix it.
Mail sent to facebook people.
Assignee: english-us → blizzard
Status: NEW → ASSIGNED
(In reply to comment #1)
> Mail sent to facebook people.

I'm willing to talk to them about this if they need my help.  I'd actually like to urge them to drop overflow:hidden too, so that our users don't get bitten by bug 631169.
I don't think overflow:hidden is the real problem with bug 631169 on their end.

I think the bigger question is why Facebook Messages overflow:hidden boxes are limited to 21 lines in height, while other overflow:hidden boxes on the Facebook site (e.g. when you are commenting on someone's status entry) grow infinitely, avoiding the problem in bug 631169 while allowing for that no-scrollbar look they favour. When talking to them, perhaps it can be confirmed whether they intended this, or whether they made a mistake limiting the messages boxes to 21 lines?
(In reply to comment #3)
> I don't think overflow:hidden is the real problem with bug 631169 on their end.
> 
> I think the bigger question is why Facebook Messages overflow:hidden boxes are
> limited to 21 lines in height, while other overflow:hidden boxes on the
> Facebook site (e.g. when you are commenting on someone's status entry) grow
> infinitely, avoiding the problem in bug 631169 while allowing for that
> no-scrollbar look they favour. When talking to them, perhaps it can be
> confirmed whether they intended this, or whether they made a mistake limiting
> the messages boxes to 21 lines?

I think that's (sort of) intended, as it seems that it's their javascript code which changes the height.
It is still an issue?
Component: English US → Desktop
I see the height change when it needs to..
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.