PrepareAndDispatch is only referenced from inline assembly

RESOLVED WONTFIX

Status

()

Core
XPConnect
RESOLVED WONTFIX
7 years ago
4 years ago

People

(Reporter: espindola, Assigned: espindola)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 512953 [details] [diff] [review]
Move the inline assembly to a asm file

When doing LTO the liker has to know all the undefined symbols in order to decide what it can drop. Since LTO happens at the IL level, undefined references in inline assembly are not seem.

Since PrepareAndDispatch is only referenced from inline assembly, the linker thinks it can be dropped.
Created attachment 513003 [details] [diff] [review]
updated patch

Updated to handle the reprocessing correctly. It is not looking a lot better than the "-Wl,-u" hack :-(
Assignee: nobody → respindola
Attachment #512953 - Attachment is obsolete: true
Status: NEW → ASSIGNED
I managed to get LLVM to parse the inline assembly when doing LTO.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
Duplicate of this bug: 949472
You need to log in before you can comment on or make changes to this bug.