Closed Bug 635090 Opened 9 years ago Closed 9 years ago

Multiple instances of plugin-container.exe spawn when closing Seamonkey and, if installed, launches acrobat.exe

Categories

(Core :: Plug-ins, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 633427

People

(Reporter: thee.chicago.wolf, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre SeaMonkey/2.1b3pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre SeaMonkey/2.1b3pre

In having just updated to the 20110217 build, I noticed a lot of disk activity when I closed it. It took 3-5 seconds before I could re-launch it. Opening up task manager, I noticed 21 instances (in my case) of plugin-container.exe were spawned and then, after about 3-5 seconds, terminated by themselves.

Reproducible: Always

Steps to Reproduce:
1. Update to the 20110217 build
2. Open up to http://www.google.com (my default home page)
3. Start Task Manager on view the Processes tab
4. Quit Seamonkey
Actual Results:  
In my case, 21 instances of plugin-container.exe spawn briefly consuming 306+ MB RAM, disk thrashes, after 3-5 seconds all plugin-container.exe processes quit.

Expected Results:  
Seamonkey and any instances of plugin-container.exe should terminate without spawning any new instances of plugin-container.exe.
Ok, this gets even more strange. I was just timing the amount of time it takes for the multiple instances of plugin-container.exe to spawn (closer to 5-7 seconds) when I close Seamonkey and noticed it launches my acrobat.exe (which you will notice from the screen grab). I didn't notice this at first because I had a PDF open earlier so I thought it was just still resident.

I did an end-task on acrobat.exe before I exited Seamonkey so it was not there. As soon as I exit Seamonkey it launches acrobat.exe though acrobat doesn't actually launch or aappear on the screen. It just simple starts an instance of it and it shows up in task manager. Repeatable 100% of the time. I have Acrobat Pro 8.2.6 installed if it matter.
Summary: Multiple instances of plugin-container.exe spawn when closing Seamonkey → Multiple instances of plugin-container.exe spawn when closing Seamonkey and, if installed, launches acrobat.exe
Ok, this gets even more strange. I was just timing the amount of time it takes for the multiple instances of plugin-container.exe to spawn (closer to 5-7 seconds) when I close Seamonkey and noticed it launches my acrobat.exe (which you will notice from the screen grab). I didn't notice this at first because I had a PDF open earlier so I thought it was just still resident.

I did an end-task on acrobat.exe before I exited Seamonkey so it was not there. As soon as I exit Seamonkey it launches acrobat.exe though acrobat doesn't actually launch or appear on the screen. It just simple starts an instance of it and it shows up in task manager. Repeatable 100% of the time. I have Acrobat Pro 8.2.6 installed if it matter.
Does this occur in safe mode?
<http://kb.mozillazine.org/Safe_Mode#Windows>
Also Try: Go Tools->Addons
And then in the plugin tab disable the acrobat plugin.
All right, here's some more info.

1) While exiting Seamonkey in Safe-Mode, an instance of Acrobat.exe still spawns but I don't see any instances of plugin-container.exe spawning.

2) Disabling the Acrobat plugin while exiting in safe-mode still spawns an instance of Acrobat.exe but no instances of plugin-container.exe.

3) Disabling the Acrobat plugin while exiting and not being in safe-mode still spawns an instance of Acrobat.exe and some instances of plugin-container.exe.
Is there a reason you have the full version of Acrobat (not just acrobat reader) installed? If not try uninstalling otherwise go into the Acrobat configuration options and deselect anything to do with browser integration.
I create fillable PDF forms so I need Pro to do them. Incidentally, I updated my home PC to the 20110217 and saw the same behavior. My home box has Acrobat Pro 7.1.4 so it doesn't *seem* to be version specific. I'll try the browser integration suggestion. Just a side note, this wasn't happening with 20110216 so something between 20110217 and 20110216 changed to cause this.
Update my home PC to 20110219 and the behavior seems to be gone. Will test my office PC on Monday.
I can confirm that build 20110217 through 20110219 contain this bug. Updated to 20110220 just now on my office PC and the behavior seems to have gone away. For all intents and purposes, it now WFM.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Version: unspecified → Trunk
Well, it looks this behavior is back with build 20110224. Although on the plus side of things, it doesn't seem to spawn as many plugin-container.exe as it did before. I see only a couple spawning this time.

Steps to repeat:

1. Update to the new nightly 20110224
2. Open task manager to observe the behavior
3. Close Seamonkey

Expected Results:

1. Seamonkey closes gracefully and does not spawn Acrobat.exe

Actual results: 

1. Seamonkey closes gracefully (?) and does spawn Acrobat.exe
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
I'll pass this over to the plugin guys to see if they have any insights on this.
Component: General → Plug-ins
Product: SeaMonkey → Core
QA Contact: general → plugins
This is clear-private-data on shutdown loading all plugins. It's a dup, but I can't find the other one right now.
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 633427
You need to log in before you can comment on or make changes to this bug.