Closed Bug 635142 Opened 10 years ago Closed 10 years ago

<strong> not showing bold text

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: jack.yan, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre

I’m using one of the templates for Tumblr and notice that <strong> is not bolding the text. While I realize the designer has not put in a Doctype, Firefox 3, IE8 and Opera have no problems (Chrome 7–9 do). I had hoped there’d still be some kind of quirks’ mode for Firefox 4.

Strangely, I can go to a really old page I did in 2004 (e.g. http://lucire.com/2004a/0122fe0.shtml) with no Doctype, and the bolds render correctly (admittedly using the <b> tag). 

I also have this no-Doctype page I did in 2004, with <strong> surrounding Amsterdam and the date in the text. Here, it seems to work: http://jyanet.com/0102pr0.htm.

To me, it seems to be unrelated to Doctype if two pages without a spec show <strong> differently.

On the Tumblr page, the font specified has the bold weight called Heavy; in the Amsterdam page, the bold weight is called Extra Bold.

Reproducible: Sometimes

Steps to Reproduce:
1. Visit jackyan.tumblr.com.
2. Note all headings (first few words in each entry) should be in bold, but are not.
3.
Actual Results:  
Bolded text appears as roman on this page with no Doctype and <strong> denoting the bold text.

Expected Results:  
Bolded text appearing as bold.

The font family I have specified at jackyan.tumblr.com has a bold weight that is called Heavy. However, it is correctly marked as a bold font in its settings (weight at 800).
As it stands weight of body (font-weight: 300) is 400 and strong 400;
Changing body to 400 (or even 301) gives 400 and 700.

Which seems to be the correct behaviour from
http://www.w3.org/Style/css2-updates/css2/fonts.html#propdef-font-weight
(bug 93725)
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → style-system
Version: unspecified → Trunk
Thanks, John. I didn’t do the CSS on this one but I have changed the 300 to 400. I’ll see how Beta 12 goes (currently downloading something on 3·6).
John, thank you—that indeed was what was happening. Marking this closed.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Blocks: 638208
No longer blocks: 638208
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.