Switch to tab shows only one tab for same url, switches to a different one from this url group (different titles)

VERIFIED DUPLICATE of bug 558354

Status

()

defect
VERIFIED DUPLICATE of bug 558354
8 years ago
8 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre

Typing the address of an already open tab offers it in the autocomplete results ("switch to tab"). If the same url has been opened multiple times and shows different content (due to iframes, javascript etc.), "switch to tab" offers only one of those tabs end selecting it will jump to a different one than that one.

Steps to reproduce:
1. Start Firefox.
2. Open http://maps.google.com in the location bar.
3. Search there for Toronto.
4. Open a new tab and load http://maps.google.com
5. Open a new tab and type "maps".

Actual result:
Only one tab offered with title "Google Maps". Selecting it will set the focus to the first tab which has the title "toronto - google maps".

Expected results:
At least to set the focus to the tab whose title is shown in switch to tab, furthermore preferring to see all matching tabs in switch to tab.
OS: Windows XP → All
Hardware: x86 → All

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558354
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.