Closed Bug 635442 Opened 9 years ago Closed 9 years ago

Crash [@ nsSVGComponentTransferFunctionElement::DidAnimateNumberList]

Categories

(Core :: SVG, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla2.0b12

People

(Reporter: jruderman, Assigned: longsonr)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, testcase)

Crash Data

Attachments

(3 files)

Based on layout/reftests/svg/smil/anim-feFuncR-tableValues-01.svg
Attached file stack trace
Attached patch patchSplinter Review
I'll turn the testcase into a crashtest.
Assignee: nobody → longsonr
Attachment #513797 - Flags: review?(dholbert)
Boris, this also affects nsSVGUtils::GetParentElement
Keywords: regression
OS: Mac OS X → All
Hardware: x86 → All
Comment on attachment 513797 [details] [diff] [review]
patch

>diff --git a/content/svg/content/src/nsSVGFilters.cpp b/content/svg/content/src/nsSVGFilters.cpp
>+inline static void DidAnimateAttrViaParent(Element *aFilterPrimitive) {

Nit: Perhaps insert a newline just before the function name, to match general mozilla style for function-definitions in .cpp files?

r=dholbert
Attachment #513797 - Flags: review?(dholbert) → review+
Flags: in-testsuite?
Attachment #513797 - Flags: approval2.0?
Can this be approved for 2.0?
Keywords: checkin-needed
I did not fix the code style thing in comment 4 before pushing since the file itself doesn't seem to be consistent, and previous helpers are using same style as this one. Maybe you want a separate bug to fix code style in this file.

http://hg.mozilla.org/mozilla-central/rev/914d4d888c72
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: in-testsuite? → in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b12
Thanks! Yeah, that style nit isn't worth filing a bug on. :) It's fine as-is.
Crash Signature: [@ nsSVGComponentTransferFunctionElement::DidAnimateNumberList]
You need to log in before you can comment on or make changes to this bug.