Last Comment Bug 635499 - Implement the max attribute for <input type='number'>
: Implement the max attribute for <input type='number'>
Status: RESOLVED FIXED
: doc-bug-filed, html5
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal with 2 votes (vote)
: mozilla16
Assigned To: Mounir Lamouri (:mounir)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on: 636750 802455
Blocks: 563637 344616 635553 635554
  Show dependency treegraph
 
Reported: 2011-02-19 08:15 PST by Mounir Lamouri (:mounir)
Modified: 2013-04-27 15:07 PDT (History)
7 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part 1 - Add the attribute (3.79 KB, patch)
2011-02-21 10:18 PST, Mounir Lamouri (:mounir)
jonas: review+
Details | Diff | Splinter Review
Part 2 - Constraint validation (16.78 KB, patch)
2011-02-21 10:18 PST, Mounir Lamouri (:mounir)
no flags Details | Diff | Splinter Review
Part 2 - Constraint validation (17.27 KB, patch)
2011-02-28 08:00 PST, Mounir Lamouri (:mounir)
jonas: review+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2011-02-19 08:15:01 PST

    
Comment 1 Mounir Lamouri (:mounir) 2011-02-21 10:18:19 PST
Created attachment 514043 [details] [diff] [review]
Part 1 - Add the attribute
Comment 2 Mounir Lamouri (:mounir) 2011-02-21 10:18:54 PST
Created attachment 514044 [details] [diff] [review]
Part 2 - Constraint validation
Comment 3 Mounir Lamouri (:mounir) 2011-02-28 08:00:39 PST
Created attachment 515625 [details] [diff] [review]
Part 2 - Constraint validation

Use with double instead of float.
Comment 5 Jonathan Watt [:jwatt] 2013-01-14 16:42:52 PST
I know this is per the current spec, but I'm wondering why this IDL attribute is a DOMString rather than double.
Comment 6 Mounir Lamouri (:mounir) 2013-01-15 04:14:52 PST
(In reply to Jonathan Watt [:jwatt] from comment #5)
> I know this is per the current spec, but I'm wondering why this IDL
> attribute is a DOMString rather than double.

Because some input types (like time, date, datetime, week, month, etc.) will define something else than numbers in max (and min).
Comment 7 Florian Scholz [:fscholz] (MDN) 2013-04-27 15:07:28 PDT
See bug 866457 for documentation.

Note You need to log in before you can comment on or make changes to this bug.