Unqualified function invocation doesn't use the global object the property was gotten from as |this|, part deux!

RESOLVED DUPLICATE of bug 634590

Status

()

P1
major
RESOLVED DUPLICATE of bug 634590
8 years ago
5 years ago

People

(Reporter: brendan, Assigned: brendan)

Tracking

({regression, testcase})

unspecified
mozilla2.0b12
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [hardblocker])

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

8 years ago
Created attachment 513837 [details] [diff] [review]
proposed fix and tests

See bug 634590 comment 74 -- Threat Level Midnight!

/be
Attachment #513837 - Flags: review?(gal)
(Assignee)

Updated

8 years ago
Summary: Unqualified function invocation doesn't use the global object the property was gotten from as |this| → Unqualified function invocation doesn't use the global object the property was gotten from as |this|, part deux!
(Assignee)

Comment 1

8 years ago
Created attachment 513839 [details] [diff] [review]
non-clownshoes result for the 'd' test

Forgot to pass true to the outer f() call.

/be
Attachment #513837 - Attachment is obsolete: true
Attachment #513837 - Flags: review?(gal)
Attachment #513839 - Flags: review?(gal)

Comment 2

8 years ago
Comment on attachment 513839 [details] [diff] [review]
non-clownshoes result for the 'd' test

ComuteThis makes more sense than SlowThis now. I like that we go through the same path for both slow and fast case now. It might cost a cycle, but the interpreter rarely kicks in and this is definitely safe now.
Attachment #513839 - Flags: review?(gal) → review+
(Assignee)

Comment 3

8 years ago
Created attachment 513842 [details] [diff] [review]
patch to commit
Attachment #513839 - Attachment is obsolete: true
Attachment #513842 - Flags: review+
(Assignee)

Comment 4

8 years ago
http://hg.mozilla.org/tracemonkey/rev/c307f596458f

/be
Whiteboard: fixed-in-tracemonkey
(Assignee)

Updated

8 years ago
Attachment #513842 - Flags: approval2.0?

Updated

8 years ago
Whiteboard: fixed-in-tracemonkey → [hardblocker][has patch], fixed-in-tracemonkey

Comment 5

8 years ago
Comment on attachment 513842 [details] [diff] [review]
patch to commit

The previous (partially incorrect) fix for this was a hardblocker, so is this then.
Attachment #513842 - Flags: approval2.0? → approval2.0+
Backed out of TM, the predecessor turned OS X opt orange.

http://hg.mozilla.org/tracemonkey/rev/600fb260cffd
Whiteboard: [hardblocker][has patch], fixed-in-tracemonkey → [hardblocker][has patch]

Updated

8 years ago
Whiteboard: [hardblocker][has patch] → [hardblocker]

Comment 9

8 years ago
what is happening with these last two beta N blockers than?

Comment 10

8 years ago
(In reply to comment #9)
> what is happening with these last two beta N blockers than?

Please see comment 8.  Apparently, the patch was applied, but something with the code caused a problem on Macintosh OS X operating system.  All operating systems have to test OKAY after the patch is applied for the patch to remain, otherwise it is taken out and rewritten.

Comment 11

8 years ago
Dup-ed against the original bug (part I) since both parts were backed out.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 634590
(Assignee)

Updated

8 years ago
Blocks: 671947
You need to log in before you can comment on or make changes to this bug.