Loading a tab crashes fennec [@ nsTableFrame::DisplayGenericTablePart ]

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

({crash, reproducible})

Trunk
Other
Linux
crash, reproducible
Points:
---

Firefox Tracking Flags

(fennec2.0+)

Details

(crash signature)

(Reporter)

Comment 1

7 years ago
 Forgot to mention that it is only the tab which crashes.
tracking-fennec: --- → ?
Keywords: crash, reproducible
(Reporter)

Updated

7 years ago
Summary: Loading a tab crashes fennec → Loading a tab crashes fennec [@ nsTableFrame::DisplayGenericTablePart ]
Whiteboard: [need-str]
need STR to consider its blocking status
I can repro this just by loading http://reroad.blogspot.com/ on Android.
tracking-fennec: ? → 2.0+
Whiteboard: [need-str]
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> I can repro this just by loading http://reroad.blogspot.com/ on Android.

Yes, that is the only STR one needs to reproduce.
That stack in the crash report looks totally wrong...

Can anyone reproduce this in a debug build?

Comment 6

7 years ago
no crash on g2 running a build from the trunk.

Comment 7

7 years ago
i did notice that there are two html5 videos on that site.  on older builds, we did preload a bunch of data for each video.  wesj did fix that for the beta5.

matt, are you using the nightly?
I was using a local trunk build before, and reproduced the crash on G2 and on Galaxy Tab.

Today, using both the nightly and a more recent local build, I cannot reproduce the crash.

Comment 9

7 years ago
I cannot reproduce this on a Galaxy S with a build from yesterday. I can even play the video elements successfully.
Please reopen if anyone is still seeing this in the latest nightly builds.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

7 years ago
Note that I don't think that this bug was actually fixed.  It's just that the site in question is a micro-blog, and is changing frequently, so I think this is now WFM because of the markup changes on the website...
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsTableFrame::DisplayGenericTablePart ]
You need to log in before you can comment on or make changes to this bug.