Closed Bug 635608 Opened 9 years ago Closed 9 years ago

Clean up sizemode=normal & disablechrome styling for aero glass

Categories

(Firefox :: Theme, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 4.0

People

(Reporter: dao, Assigned: dao)

Details

Attachments

(1 file)

Attached patch patchSplinter Review
The rules handling this are useless overhead, the non-glass code handles it just fine.
Attachment #513863 - Flags: review?(fryn)
Comment on attachment 513863 [details] [diff] [review]
patch

Re-read the corresponding styling in browser.css to understand the reasoning for this.

It makes sense to me.
Attachment #513863 - Flags: review?(fryn)
Attachment #513863 - Flags: review+
Attachment #513863 - Flags: approval2.0?
I get nervous, despite this being a CSS change - what's the plan to watch for unintentional regressions (which we've seen, especially around the title bar in full screen mode). Happy to be convinced to take this, but not sure that the reward is worth the risk.
The risk is relatively low, as this removes code that's only used for restored windows with aero glass, in favor of simpler code that's already used in maximized windows or without aero glass. The reward is a more consistent implementation, which makes it easier to deal with last-minute polish or bugs, should they come up.
Comment on attachment 513863 [details] [diff] [review]
patch

a=beltzner
Attachment #513863 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/e4c1bf9e0a35
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b12
Target Milestone: Firefox 4.0b12 → Firefox 4.0
You need to log in before you can comment on or make changes to this bug.