Closed Bug 635715 Opened 12 years ago Closed 12 years ago

web.ebuddy.com messenger chat broken as of 2011-02-04 nightly

Categories

(Core :: XPConnect, defect)

x86
All
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 633133
Tracking Status
blocking2.0 --- final+

People

(Reporter: bloganz, Assigned: mrbkap)

References

()

Details

(Keywords: regression, Whiteboard: [hardblocker])

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110221 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110221 Firefox/4.0b12pre

www.ebuddy.com on this site anfter typing "Passport" and "Password" a page (http://web.ebuddy.com/?startsession=1) will popup ,which loads the messenger where you can chat,but since Firefox 4.12pre this site lodas but saty empty even with reloading the site ,nothing happens.

Reproducible: Always

Steps to Reproduce:
1.type www.ebuddy.com in the adress bar 
2.type "passport" & "password"
3.a page will popup 
4.the page loads 
5.and the page show just the background image
Actual Results:  
same result empty page

Expected Results:  
it should load a page with a chat site

i'm a using a fresh & clean install of firefox 4.12pre on WIN7_x64,with no addons and themes
Correcting platform, since your user agent indicates 32bit build (platform refers to Minefield build, not OS).

Would you be able to try and find the regression range:
https://wiki.mozilla.org/QA/Triage#How_to_Help_with_Regressions_--_Finding_Regression_Windows

(Please post the revision IDs from about:buildconfig rather than just the dates - thanks!)
Hardware: x86_64 → x86
Summary: the site loads but there is nothing to see,just the background image → web.ebuddy.com fails to load on latest nightly (site loads but there is nothing to see, just the background image)
Version: unspecified → Trunk
4.0b12pre(2001-02-03)...was the last 12pre release that could open the page correctly, after that none of the nightly releases worked 



about:buildconfig
Source

Built from http://hg.mozilla.org/mozilla-central/rev/094a7967e171
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -wd4800 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
Configure arguments

--enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-tests
Great - thanks!

This gives...

Last good nightly: 2011-02-03
First bad nightly: 2011-02-04

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=094a7967e171&tochange=847a825087f2

Could you try with Fx 4 beta 11, since it quite handily splits that range up even more, since it was built halfway between the two nightlies:
ftp://ftp.mozilla.org/pub/firefox/releases/4.0b11/
blocking2.0: --- → ?
Summary: web.ebuddy.com fails to load on latest nightly (site loads but there is nothing to see, just the background image) → web.ebuddy.com messenger chat broken as of 2011-02-04 nightly
i'm alrealy using the 4.0b11 since 02-04 :) and no problems here 

http://img683.imageshack.us/img683/3600/ebuddyf.jpg


about:buildconfig
Source

Built from http://hg.mozilla.org/mozilla-central/rev/f9d66f4d17bf
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\rel-cen-w32-bld\build\build\cl.py cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\rel-cen-w32-bld\build\build\cl.py cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -wd4800 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
Configure arguments

--enable-application=browser --enable-update-channel=beta --enable-update-packaging --enable-jemalloc --enable-tests --enable-official-branding
Reduced range...

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f9d66f4d17bf
&tochange=847a825087f2
Status: UNCONFIRMED → NEW
Ever confirmed: true
blocking2.0: ? → final+
Whiteboard: [hardblocker]
WFM. Win 7 Pro 32bit.
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110222 Firefox/4.0b12pre (latest nightly)
Built from http://hg.mozilla.org/mozilla-central/rev/1da3405c74fd
http://img405.imageshack.us/img405/6434/95863831.jpg
The first bad revision is:
changeset:   61730:ed958cdc8396
user:        Blake Kaplan <mrbkap@gmail.com>
date:        Wed Feb 02 22:05:07 2011 -0800
summary:     Bug 630716 - Use a better method of comparing URIs for determining whether two compartments are same origin. r=bzbarsky, r=gal, a=blocker
This is NOT WFM for me on 1da3405c74fd (same revision ad Eddward's), but I need to log in from www.ebuddy.com instead of web.ebuddy.com.
Component: General → XPConnect
Product: Firefox → Core
QA Contact: general → xpconnect
(In reply to comment #10)
> This is NOT WFM for me on 1da3405c74fd (same revision ad Eddward's), but I need
> to log in from www.ebuddy.com instead of web.ebuddy.com.

I can confirm this. (NOT WFM from www.ebuddy.com)
Adding gal, document.domain's biggest fan.
Can someone check the error log? Are we throwing any security exceptions?
It looks like my chase.com fix isn't entirely working. I'll debug it tomorrow.
I am out of blockers and available to help.
@Mike Shaver ..loggin from web.ebuddy.com is ok ,but if with www.ebuddy.com,i get this error (bug).

http://img511.imageshack.us/img511/8094/ebuddy1.jpg
ss you can see still nothing happens,and i'm testing all nightly builds since 02-03

now testing 
Built from http://hg.mozilla.org/mozilla-central/rev/f8279991d58f
Thanks, Blake.

Chango: when it fails, do you see anything in the error console? (ctrl-shift-J)
Assignee: nobody → mrbkap
Error: u is undefined
Source File: http://lcontent.ebuddy.com/web/va1.9.4/js/core.js
Line: 785

u is probably defined by u=window.opener.document.forms["login-form"]
Same as Maurício Collares Neto 

Error: u is undefined
Source File: http://lcontent.ebuddy.com/web/va1.9.4/js/core.js
Line: 785


Error:
http://lukaanz.lu.ohost.de/bug/error.jpg
Warnings:
http://lukaanz.lu.ohost.de/bug/warnings.jpg
I don't know if this helps, but here are the contents of a few variables as seen by Firebug:

>>> window.opener.document.forms
[form#cse-search-box cse, form#login-form, form#ie6_login_form dispatch]
>>> window.opener.document.forms["login-form"]
undefined
>>> window.opener.document.forms[1]
<form id="login-form" class="" method="POST" action="">
Blake says this is fixed by Mounir's patch in bug 633133, duping, and making this a blocker.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 633133
You need to log in before you can comment on or make changes to this bug.