audi.ca/fr/co.uk/de configurator does not load

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

({regression})

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110221 Firefox/4.0b12pre

The audi.ca configurator (a tool to option out and build a car found at http://configurator.audi.ca/en, which redirects to http://configurator.audi.ca/entry?mandant=accx-ca-en) does not load in Firefox 4 (I've tested this on the latest nightly on another system; the system on which I am writing this bug report is running the 20110217 nightly).

I have confirmed that the web site works with Chrome, and works with Firefox 3.6.13. I tried spoofing a Firefox 3.6.13 UA, no change in behaviour, so I suspect not a TE issue.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 514152 [details]
Broken web site in 20110217 nightly (looks the same in 20110221)
(Reporter)

Comment 2

8 years ago
Created attachment 514154 [details]
Working web site in 3.6.13
(Reporter)

Comment 3

8 years ago
Some other international Audi sites (that seem to use the same design and presumably similar/identical code as Canada) seem to be broken in the same way. See, e.g.:
http://configurator.audi.co.uk/?.html.html (UK)
http://configurator.audi.fr/ (France)
http://konfigurator.audi.de/entry (Germany)
(I didn't test those with a 3.6.13 UA, but I did test them in real 3.6, they seemed to load there)

U.S. site appears to use totally different code. Australia/Ireland/Luxembourg/Hong Kong are also fine and appear to share a similar (different from Canada/UK/France/Germany) design. Couldn't find a configurator on New Zealand. Belgium uses a Java-based tool. Austria has a different configurator tool too. My language skills are limited to English and French (though it's a safe bet that 'Konfigurator' on the German-language sites refers to the same thing), so I figured that that would be enough countries. :)
(Reporter)

Updated

8 years ago
Summary: audi.ca configurator does not load → audi.ca/fr/co.uk/de configurator does not load

Comment 4

8 years ago
Confirmed.

Works fine in 3.6.13, 3.6.14
The site is not being loaded from Firefox 4 Beta 1

Error Console:

Error: Applying the 'delete' operator to an unqualified name is deprecated
Source File: http://configurator.audi.ca/v6-tpl-accx/js/all.vmjs?v=2011-02-09
Line: 1950, Column: 6
Source Code:
      delete _animateToPosition; 

Error: jQuery is not defined
Source File: http://configurator.audi.ca/entry?mandant=accx-ca-en
Line: 54

Error: jQuery is not defined
Source File: http://configurator.audi.ca/entry?mandant=accx-ca-en
Line: 204

Error: jQuery is not defined
Source File: http://configurator.audi.ca/entry?mandant=accx-ca-en
Line: 605

Error: jQuery is not defined
Source File: http://configurator.audi.ca/entry?mandant=accx-ca-en
Line: 1
Using m-c...
Last good nightly: 2009-12-01 
First bad nightly: 2009-12-02
Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7f3c1c9fb57&tochange=a5e1b195ecf7

Using TM...
Last good nightly: 2009-11-19 
First bad nightly: 2009-11-20
Pushlog: http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=c84622414ed3&tochange=2ca2a236da89

Gather from the changesets in those ranges and the errors shown in the error console that this is another case of 'script running in script mode when it really shouldn't be', so tech evang. 

However, going to nom for blocking/visibility, for someone else to make the call.
Assignee: nobody → general
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Component: General → JavaScript Engine
Ever confirmed: true
Keywords: regression
QA Contact: general → general
Whiteboard: [Tech evang?]
Version: unspecified → Trunk
(In reply to comment #5)
>'script running in script mode when it really shouldn't be', so tech evang.

Strict mode even...

Comment 7

8 years ago
dupe of bug 631043
Sort of, yes.  It sounds like a lot more than just the .de version is affected...
Assignee: general → english-other
blocking2.0: ? → ---
Component: JavaScript Engine → English Other
Depends on: 631043
Product: Core → Tech Evangelism
QA Contact: general → english-other
Whiteboard: [Tech evang?]
Version: Trunk → unspecified
This is now a product side tracking bug for bug 631043 - do we believe we can't ship without that Tech Evangelism bug resolved? That's the blocking decision, here.
Mike, do you want me to move this back out of evang?
I think we can ship without this resolved.  And really, I don't see what option we have here if they're feeding us drek.  I don't think we can, or should, special-case sites as able or unable to invoke strict mode.  And turning it off isn't an option, either, for spec compliance and for compatibility with other upcoming implementations that do support it.  I don't think anyone else has seriously discussed disabling strict mode.  I don't think we should either.
(Reporter)

Comment 12

8 years ago
audi.ca configurator now seems to work, so I presume they've fixed their code...
(In reply to mozilla from comment #12)
> audi.ca configurator now seems to work, so I presume they've fixed their
> code...

This also works fine for me in FF9.0.1. If there is still an issue that I missed, please reopen with additional info.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.