Scrolling a bullet list cause redering glitch

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: matxdr, Assigned: kmcclusk)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; m18) Gecko/20001218
BuildID:    2000121804

I've noticed this problem on validartor.w3.org.  When you scroll a bullet list
with the slide bar, some bullets generates a lower right diagonal line, most of
the time to the next text line, sometimes longer than this.  ALT-TABbing from a
window to another cause refresh and solve the glitch.  This appends only when
scrolling up.

Reproducible: Always
Steps to Reproduce:
Load the testcase file I included.
Scroll the page with the scrollbar to the bottom and then scroll up slowly.
Notice the glitch.

Actual Results:  bullets generates diag lines to lower right		

Expected Results:  Only bullets, no lines
(Reporter)

Comment 1

18 years ago
Created attachment 21199 [details]
A page and a half of bullet list

Comment 2

18 years ago
Moving to XP Toolkit/Widgets, confirming.

This bug does not occur on win98
Assignee: asa → trudelle
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Toolkit/Widgets
Ever confirmed: true
QA Contact: doronr → jrgm

Comment 3

18 years ago
Reporter, what video card and driver are you using?  I've seen this bug before,
a long time ago, and it was fixed with a newer display driver for me.
(Reporter)

Comment 4

18 years ago
I'm using Win ME, Diamond Viper 2 card with lastest driver found on Diamond's 
site, and Direct X 8.0

Comment 5

18 years ago
This has nothing to do with the toolkit. ->kmcclusk
Assignee: trudelle → kmcclusk

Comment 6

18 years ago
Reporter, sad to say, this is a Viper 2 driver bug.  I should know, as I work at
S3, and I'm the one who originally reported the bug to get it fixed here.  Get
the latest reference driver (should be higher than v9.51.06, if I recall, for
the fix) from the www.s3graphics.com site, and it *should* fix this problem.
It's certainly gone for me.  Someone should close this bug, too.  I'm not sure
how to change the status.

Comment 7

18 years ago
resolving as worksforme, reopen if there are still problems.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

18 years ago
I only found v9.51.03 on s3graphics.com.  Anyway, let's not loose time on this 
one since it's a known driver issue.  But I'm still wondering why this problem 
occurs only with Mozilla, and not with IE5 and NS4.7x?

Comment 9

18 years ago
Not sure why, but going with vrfy :-]
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

18 years ago
Good call, since I can't see this with 122920!  I guess that another fix fixed
this one too.  
You need to log in before you can comment on or make changes to this bug.